Bug 619481 - pdfTeX error (ext4): \pdfendlink ended up in different nesting level than \pdfstartlink
pdfTeX error (ext4): \pdfendlink ended up in different nesting level than \pd...
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: texlive (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Jindrich Novy
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-07-29 12:20 EDT by Tom Lane
Modified: 2013-08-12 21:19 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-10-07 04:16:37 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tom Lane 2010-07-29 12:20:01 EDT
Description of problem:
I'm getting the mentioned error when trying to build recent postgresql documentation as a US-paper-size PDF file.  Oddly, the A4-paper-size build goes through fine, and that's the identical source files and no difference except for the -V '%paper-type%'=USletter or A4 switch.

I've tried to investigate this but soon get lost in a maze of TeX macros; I can't even tell for sure which component is at fault.  Am blaming jadetex for starters since it's pdfjadetex issuing the error.

Version-Release number of selected component (if applicable):
jadetex-3.13-8.fc12.noarch

How reproducible:
100%

Steps to Reproduce:
1. Use an F-13 machine with standard authoring packages installed.
2. Get postgresql 9.0 beta3 source tarball from http://www.postgresql.org/ftp/source/
    (use beta3, not beta4 or later, because I'm going to put some sort of hack workaround into beta4)
3. Unpack tarball, cd into top level directory, run ./configure
4. cd doc/src/sgml
5. make postgres-US.pdf
  
Actual results:
Runs for 10 minutes or so and then fails with error shown in summary

Expected results:
Should complete the build

Additional info:
For investigation it may help to "make postgres-US.tex-pdf" first, else make will remove that intermediate file after the failure and you have to start the whole build process over again if you want to try again.
Comment 1 Tom Lane 2010-07-29 14:35:49 EDT
Further experimentation shows that transforming the "AIX-fixlevels" table to a <variablelist> masks the problem, so that's what you'll see if you try beta4 or later.  That makes the problem un-urgent from my perspective, although without knowing what's causing it, I'm worried that it might come back in the future.
Comment 2 Ondrej Vasik 2010-08-16 09:54:05 EDT
pdfjadetex is just a symlink to pdfetex ... After googling a bit about this issue it looks like hyperlinks and page boundary is the culprit. As the page size differs for A4 it probably has some luck and just passes the problematic place.
Anyway - reassigning to texlive.
Comment 3 Bug Zapper 2011-06-01 08:33:36 EDT
This message is a reminder that Fedora 13 is nearing its end of life.
Approximately 30 (thirty) days from now Fedora will stop maintaining
and issuing updates for Fedora 13.  It is Fedora's policy to close all
bug reports from releases that are no longer maintained.  At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '13'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 13's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 13 is end of life.  If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora please change the 'version' of this 
bug to the applicable version.  If you are unable to change the version, 
please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events.  Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 4 Tom Lane 2011-06-01 09:54:18 EDT
Oh dear, I had forgotten I'd filed this bug, or I would have updated it.

We did work out, much later, the proximate cause of this error message: it happens when there's a <link> ... </link> construct and the text to be link-ified crosses a page boundary in the PDF output.  The various voodoo fixes mentioned above worked by changing vertical spacing enough so the link text no longer crossed a page boundary.

I'm not sure how fixable this is, but if it can't be fixed to remove the error condition, it would sure be nice if the error message were more helpful.  It doesn't really tell you what the problem is, and it doesn't identify the source SGML location.
Comment 5 Benjamin Kosnik 2012-04-18 14:37:12 EDT
Also ran into this, very annoying due to whitespace issues masking/making indeterminate failure. Should be higher priority.
Comment 6 Jindrich Novy 2012-10-07 04:16:37 EDT
This is now fixed in rawhide by upgrading to TeX Live 2012.
Comment 7 Tom Lane 2012-10-07 16:12:25 EDT
(In reply to comment #6)
> This is now fixed in rawhide by upgrading to TeX Live 2012.

That's very good news ... but is there any chance of getting the fix into F18?
Comment 8 Jindrich Novy 2012-10-08 01:02:12 EDT
I will try to update TeX Live in F18 to 2012 as well. So far the update process in rawhide went very smooth so there are high chances the same would apply for F18 as well.
Comment 9 Fedora Update System 2012-10-20 01:26:24 EDT
texlive-2012-3.20121019_r28030.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/texlive-2012-3.20121019_r28030.fc18
Comment 10 Tom Lane 2013-06-26 18:48:39 EDT
FYI, I'm hearing that the \pdfendlink failure is still being seen in other distros using TeX Live 2012:

http://www.postgresql.org/message-id/flat/51CB2096.2080800@pgexperts.com#51CB2096.2080800@pgexperts.com

So it wasn't really fixed, or there's another bug with the same symptom, or something.  I'm unfortunately unable to try the case with Fedora's package right this instant, so I'm not asking to reopen this bug --- yet.  But I'm curious to know what grounds you had for saying TL2012 fixed it?
Comment 11 Denis Arnaud 2013-08-12 21:19:22 EDT
In order to reproduce the bug with TexLive 2013 on Fedora 19, you can build OpenTREP (https://bugzilla.redhat.com/show_bug.cgi?id=866265#c11).

For instance, search for "Fatal error occurred, no output PDF file produced!" in http://kojipkgs.fedoraproject.org//work/tasks/29/5810029/build.log (task: http://koji.fedoraproject.org/koji/taskinfo?taskID=5810028)

When you build the package locally, you can go to the BUILD/opentrep-0.5.3/doc/latex directory and type 'make', then look for "pdfTeX error" in the refman.log file.

Hope that helps.

Note You need to log in before you can comment on or make changes to this bug.