Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 619484 - rhn-satellite-activate doesn't update 'Software Channel Entitlements' when executed in '--disconnected' mode
rhn-satellite-activate doesn't update 'Software Channel Entitlements' when ex...
Status: CLOSED NOTABUG
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Server (Show other bugs)
530
All Linux
high Severity high
: ---
: ---
Assigned To: Jan Pazdziora
Red Hat Satellite QA List
:
Depends On:
Blocks: 462714
  Show dependency treegraph
 
Reported: 2010-07-29 12:23 EDT by Vishal Gaikwad
Modified: 2011-04-11 05:11 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-04-11 05:11:27 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Vishal Gaikwad 2010-07-29 12:23:23 EDT
Description of problem:
After installation of RHN Satellite 5.3 in 'Disconnected' mode and activation using a Satellite certificate, 'Software Channel Entitlements' are not reflected on the WebUI and as a result channels cannot be sync'ed from channel dumps.

Version-Release number of selected component (if applicable):
Red Hat Network Satellite 5.3.0

How reproducible:
Always

Steps to Reproduce:
1. Setup a RHNS 530 server (Dis-connected), install it with .install.pl --disconncted

2. Login to the WebUI and then Overview -> Subscriptions -> Software Channel Entitlements -> Shows 'Private Channel Family 1'

3. Took the same cert and activated it in disconnected mode as:
# rhn-satellite-activate --rhn-cert=mhuth-5.3.test.cert --disconnected

4. Again Login to the WebUI and then Overview -> Subscriptions -> Software Channel Entitlements -> Shows 'Private Channel Family 1'.
  
Actual results:
WebUI -> Overview -> Subscriptions -> Software Channel Entitlements -> Shows 'Private Channel Family 1'.

Expected results:
WebUI -> Overview -> Subscriptions -> Software Channel Entitlements -> Should show channels with quantity as per the Satellite certificate.

Additional info:
A workaround is to change the RHN Satellite into connected mode and re-activate the certificate.
Comment 2 Jan Pazdziora 2010-08-17 10:23:04 EDT
I've reproduced the behaviour but I was not able to reproduce the bug.

I've installed fresh Satellite 5.3.0.

I have installed as --disconnected with certificate which has

  <rhn-cert-field name="slots">20</rhn-cert-field>
  <rhn-cert-field name="monitoring-slots">20</rhn-cert-field>
  <rhn-cert-field name="provisioning-slots">20</rhn-cert-field>
  <rhn-cert-field name="virtualization_host">20</rhn-cert-field>
  <rhn-cert-field name="channel-families" quantity="2" family="rhel-rhdirserv"/>
  <rhn-cert-field name="channel-families" quantity="20" family="rhel-server"/>
  <rhn-cert-field name="channel-families" quantity="20" family="rhel-server-supplementary"/>
  <rhn-cert-field name="channel-families" quantity="20" family="rhel-server-vt"/>
  <rhn-cert-field name="channel-families" quantity="20" family="rhn-tools"/>
  <rhn-cert-field name="satellite-version">5.3</rhn-cert-field>
  <rhn-cert-field name="generation">2</rhn-cert-field>

and then rerun rhn-satellite-activate with the same certificate, as disconnected.

Yes, it's true that the Software Channel Entitlements only shows the Private Channel Family 1  line and nothing else.

However, I had no problem syncing rhel-x86_64-server-5 from my dump

# satellite-sync -m. -c rhel-x86_64-server-5
15:07:21 Red Hat Network Satellite - file-system synchronization
15:07:21    mp:  /opt/dumps/rhel-5
15:07:21    db:  rhnsat/<password>@rhnsat
15:07:21 
15:07:21 Retrieving / parsing channel-families data
15:07:21 channel-families data complete
15:07:21 
15:07:21 Retrieving / parsing arches data
15:07:22 arches data complete
15:07:22 
15:07:22 Retrieving / parsing additional arches data
15:07:22 additional arches data complete
15:07:22 
15:07:22 Retrieving / parsing channel data
15:07:22    p = previously imported/synced channel
15:07:22    . = channel not yet imported/synced
15:07:22    base-channels:
15:07:22       . rhel-x86_64-server-5                     9810
15:07:22 
15:07:23 Channel data complete
15:07:23 
15:07:23 Retrieving / parsing blacklists data
15:07:23 blacklists data complete
15:07:23 
15:07:23 Retrieving / parsing product names data
15:07:23 
15:07:23 Retrieving short package metadata (used for indexing)
15:07:23    Retrieving / parsing short package metadata: rhel-x86_64-server-5 (9810)
15:11:32 Diffing package metadata (what's missing locally?): rhel-x86_64-server-5
            ________________________________________
Diffing:    ######################################## - complete
15:11:51 
15:11:51 Downloading rpm packages
15:11:51    Fetching any missing RPMs: rhel-x86_64-server-5 (9810)
[...]

and as soon as I did that, new line

Red Hat Enterprise Linux (core server) 	 0 	 20 

appeared in the Software Channel Entitlements. So even if the entitlements are not visible on the WebUI right after disconnected activation, it does not prevent satellite-sync from running on my 5.3.0.

Does the customer have a reproducer where the satellite-sync indeed fails?

The thing is, we cannot populate the list of channel entitlements because the list of families is imported from the sync. So at the time of disconnected Satellite activation, there isn't where to take the channel family names and other information.
Comment 6 Jan Pazdziora 2011-04-11 05:11:27 EDT
Per comment 2, I believe the behaviour is as designed.

Closing as NOTABUG.

Note You need to log in before you can comment on or make changes to this bug.