This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 619538 - Updating from F-12 (with 2.6.31 kernel) results in completely broken system
Updating from F-12 (with 2.6.31 kernel) results in completely broken system
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: glibc (Show other bugs)
rawhide
All Linux
low Severity high
: ---
: ---
Assigned To: Andreas Schwab
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F14Target
  Show dependency treegraph
 
Reported: 2010-07-29 14:56 EDT by Erik van Pienbroek
Modified: 2014-01-21 18:16 EST (History)
9 users (show)

See Also:
Fixed In Version: glibc-2.12.90-7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-08-18 21:05:06 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Erik van Pienbroek 2010-07-29 14:56:16 EDT
Hi,

Yesterday I tried to update a virtual machine containing an F-12 installation to rawhide and it resulted in a completely broken system. The glibc bundled with rawhide/F14 requires kernel 2.6.32 or higher to run binaries. However, the default F-12 image was bundled with a 2.6.31 kernel. The 2.6.32 kernel has been provided as an update for F-12 back in March this year, but it wasn't installed yet on that virtual machine when I tried to upgrade to rawhide as I hadn't used the virtual machine for some time.

After glibc was updated, all remaining package updates resulted in 'kernel too old' messages. When yum completed I tried to perform basic commands like 'ls', but it all resulted in 'kernel too old' messages. So I tried to perform a hard reboot, but as dracut (which is run while installing a new kernel) also failed to generate an initrd the new kernel didn't get installed properly.

Eventually I ended up with an unbootable system as the old kernel also couldn't be booted anymore and I had to reinstall everything.

Wouldn't it be possible to add an extra check to yum which checks for a recent enough kernel before glibc can be updated?
Comment 1 Bill Nottingham 2010-07-29 15:29:17 EDT
glibc should have:

Conflicts: kernel < 2.6.32

in its spec file.

While there still would be issues with chrooted installation, it would at least ensure that on a 'normal' system, the active kernel is new enough that the system wouldn't fall over mid-update.
Comment 2 Fedora Update System 2010-08-02 09:52:55 EDT
glibc-2.12.90-7 has been submitted as an update for Fedora 14.
http://admin.fedoraproject.org/updates/glibc-2.12.90-7
Comment 3 Fedora Update System 2010-08-02 22:13:50 EDT
glibc-2.12.90-7 has been pushed to the Fedora 14 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update glibc'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/glibc-2.12.90-7
Comment 4 Fedora Update System 2010-08-18 21:05:01 EDT
glibc-2.12.90-7 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 5 maksym 2010-11-30 04:25:51 EST
(In reply to comment #4)
> glibc-2.12.90-7 has been pushed to the Fedora 14 stable repository.  If
> problems still persist, please make note of it in this bug report.

i have a problem upgrading from FC12 to FC14, even after manual kernel update, i still have a warning like:
[...]
** Found 1 pre-existing rpmdb problem(s), 'yum check' output follows:
glibc-2.12.90-19.i686 conflicts with installed package(s) kernel < ('0', '2.6.32', None): kernel-PAE-2.6.31.5-127.fc12.i686
Comment 6 maksym 2010-11-30 04:29:34 EST
(In reply to comment #5)
> (In reply to comment #4)
> > glibc-2.12.90-7 has been pushed to the Fedora 14 stable repository.  If
> > problems still persist, please make note of it in this bug report.
> 
> i have a problem upgrading from FC12 to FC14, even after manual kernel update,
> i still have a warning like:
> [...]
> ** Found 1 pre-existing rpmdb problem(s), 'yum check' output follows:
> glibc-2.12.90-19.i686 conflicts with installed package(s) kernel < ('0',
> '2.6.32', None): kernel-PAE-2.6.31.5-127.fc12.i686

please ignore my post...
just older kernel packages must be removed...

Note You need to log in before you can comment on or make changes to this bug.