Bug 619577 - add missing SI and IEC prefixes (and add "IEC" and "JEDEC")
Summary: add missing SI and IEC prefixes (and add "IEC" and "JEDEC")
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: hunspell-en (Show other bugs)
(Show other bugs)
Version: rawhide
Hardware: All Linux
low
medium
Target Milestone: ---
Assignee: Caolan McNamara
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords: Reopened
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-07-29 20:39 UTC by Andre Robatino
Modified: 2010-07-30 21:19 UTC (History)
1 user (show)

Fixed In Version: hunspell-en-0.20100322-6.fc14
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-07-30 21:19:04 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Andre Robatino 2010-07-29 20:39:06 UTC
Description of problem:
Some of the following prefixes

                 SI
1000        k
1000^2  M   
1000^3  G
1000^4  T
1000^5  P
1000^6  E
1000^7  Z
1000^8  Y

                  IEC             
1024         Ki    
1024^2  Mi    
1024^3  Gi 
1024^4  Ti            
1024^5  Pi            
1024^6  Ei            
1024^7  Zi            
1024^8  Yi

together with the associated sizes in bits or bytes, are missing from the dictionary.  Namely,

kB, Gb, Eb, EB, Zb, ZB, Kib, KiB, Mib, MiB, GiB, Tib, TiB, Pib, PiB, Ei, Eib, EiB, Zi, Zib, ZiB, Yi, Yib, YiB

In addition, "IEC" itself is missing from the dictionary, although "SI" is present.

Version-Release number of selected component (if applicable):
hunspell-en-0.20100322-4.fc14.noarch

Additional info:
Note that the correct SI prefix for "kilo" is (unfortunately) "k" and not "K".  The above prefixes were copied and pasted from

http://en.wikipedia.org/wiki/Binary_prefixes

Comment 1 Andre Robatino 2010-07-29 21:41:04 UTC
Exactly the same missing items in F13 with hunspell-en-0.20100322-1.fc13.noarch.

Comment 2 Caolan McNamara 2010-07-30 10:47:22 UTC
There's always a tension between what should be and shouldn't be in a spell-checking dictionary, i.e. a English spell checking dictionary shouldn't necessarily contain *every* English word that exists, e.g. "calendar" is the correct spelling of that word, and "calender" is typically a misspelling of that word, but "calender" (http://en.wikipedia.org/wiki/Calender) also exists as a word, albeit an incredibly low-usage one. Accepting "calender" leads to allowing misspellings of "calendar" to escape.

So the US English dictionary sort of attempts to only contain words above a certain general usage threshold, and most of the above are inarguably exotic in the ordinary case. 

That said, Fedora gets used by the kind of geeky people that use these terms regularly, so added in.

Will be in hunspell-en-0.20100322-5.fc14

Comment 3 Andre Robatino 2010-07-30 17:46:57 UTC
I had thought about suggesting that "Kb" and "KB" be removed, since the correct SI prefix is "k", but the Binary prefixes link above mentions the JEDEC prefixes including "K", so the prefixes involving both "k" and "K" should probably be included.  So adding "kB" (as listed above) is the only change needed.  But come to think of it, you should probably add "JEDEC" as well, since that seems unlikely to be spelled accidentally.  Reopening and changing the Summary - close again to confirm.

Comment 4 Caolan McNamara 2010-07-30 18:34:47 UTC
fair enough, easy fix. Done as hunspell-en-0.20100322-6.fc14

Comment 5 Fedora Update System 2010-07-30 18:35:34 UTC
hunspell-en-0.20100322-6.fc14 has been submitted as an update for Fedora 14.
http://admin.fedoraproject.org/updates/hunspell-en-0.20100322-6.fc14

Comment 6 Fedora Update System 2010-07-30 21:18:58 UTC
hunspell-en-0.20100322-6.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.