Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 619618 - SELinux is preventing kdm_greet (xdm_t) "link" fonts_t.
SELinux is preventing kdm_greet (xdm_t) "link" fonts_t.
Status: CLOSED DUPLICATE of bug 538428
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
13
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Daniel Walsh
Fedora Extras Quality Assurance
setroubleshoot_trace_hash:12281b7102f...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-07-29 19:19 EDT by Ruediger Landmann
Modified: 2010-07-30 14:54 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-07-30 14:54:10 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ruediger Landmann 2010-07-29 19:19:18 EDT
Summary:

SELinux is preventing kdm_greet (xdm_t) "link" fonts_t.

Detailed Description:

[SELinux is in permissive mode. This access was not denied.]

SELinux denied access requested by kdm_greet. It is not expected that this
access is required by kdm_greet and this access may signal an intrusion attempt.
It is also possible that the specific version or configuration of the
application is causing it to require additional access.

Allowing Access:

You can generate a local policy module to allow this access - see FAQ
(http://fedora.redhat.com/docs/selinux-faq-fc5/#id2961385) Or you can disable
SELinux protection altogether. Disabling SELinux protection is not recommended.
Please file a bug report (http://bugzilla.redhat.com/bugzilla/enter_bug.cgi)
against this package.

Additional Information:

Source Context                system_u:system_r:xdm_t:s0-s0:c0.c1023
Target Context                system_u:object_r:fonts_t:s0
Target Objects                3830d5c3ddfd5cd38a049b759396e72e-x86.cache-2.TMP-
                              rbWgc6 [ file ]
Source                        kdm_greet
Source Path                   /usr/libexec/kde4/kdm_greet
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           kdm-4.3.1-9.fc11
Target RPM Packages           
Policy RPM                    selinux-policy-3.6.12-85.fc11
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Permissive
Plugin Name                   catchall
Host Name                     (removed)
Platform                      Linux (removed)
                              2.6.30.8-64.fc11.i586 #1 SMP Fri Sep 25 04:30:19
                              EDT 2009 i686 i686
Alert Count                   1
First Seen                    Fri 23 Oct 2009 07:54:52 AM EST
Last Seen                     Fri 23 Oct 2009 07:54:52 AM EST
Local ID                      784d34f7-12aa-41d1-b910-b0ee7c12934f
Line Numbers                  

Raw Audit Messages            

node=(removed) type=AVC msg=audit(1256248492.845:5): avc:  denied  { link } for  pid=2330 comm="kdm_greet" name="3830d5c3ddfd5cd38a049b759396e72e-x86.cache-2.TMP-rbWgc6" dev=dm-0 ino=75651 scontext=system_u:system_r:xdm_t:s0-s0:c0.c1023 tcontext=system_u:object_r:fonts_t:s0 tclass=file

node=(removed) type=SYSCALL msg=audit(1256248492.845:5): arch=40000003 syscall=9 success=yes exit=0 a0=9d1e553 a1=9d1e50b a2=3d8288 a3=9d1e470 items=0 ppid=2319 pid=2330 auid=4294967295 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 tty=(none) ses=4294967295 comm="kdm_greet" exe="/usr/libexec/kde4/kdm_greet" subj=system_u:system_r:xdm_t:s0-s0:c0.c1023 key=(null)



Hash String generated from  catchall,kdm_greet,xdm_t,fonts_t,file,link
audit2allow suggests:

#============= xdm_t ==============
allow xdm_t fonts_t:file link;
Comment 1 Daniel Walsh 2010-07-30 14:54:10 EDT

*** This bug has been marked as a duplicate of bug 538428 ***

Note You need to log in before you can comment on or make changes to this bug.