This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 619666 - Can you check if Spawning work with Eventlet 0.9.9?
Can you check if Spawning work with Eventlet 0.9.9?
Status: CLOSED ERRATA
Product: Fedora EPEL
Classification: Fedora
Component: Spawning (Show other bugs)
el5
All Linux
low Severity medium
: ---
: ---
Assigned To: Steve Milner
Fedora Extras Quality Assurance
:
Depends On:
Blocks: 618909
  Show dependency treegraph
 
Reported: 2010-07-30 02:11 EDT by Lev Shamardin
Modified: 2010-09-24 13:38 EDT (History)
2 users (show)

See Also:
Fixed In Version: python-eventlet-0.9.12-2.el5
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-09-22 10:28:21 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Lev Shamardin 2010-07-30 02:11:00 EDT
I'm considering an update of python-eventlet to Eventlet-0.9.9 for EL5. There are python-eventlet-0.9.9 builds for F14, F15 and EL6 available in Koji. Could you please check if it breaks Spawning? As repoquery reports, Spawning is the only package which depends on python-eventlet for now, so it would be good if this update is possible.
Comment 1 Steve Milner 2010-07-30 05:50:35 EDT
I'm currently traveling but will take a look and test this weekend or early next week.
Comment 2 Steve Milner 2010-07-30 05:50:35 EDT
I'm currently traveling but will take a look and test this weekend or early next week.
Comment 3 Steve Milner 2010-07-30 05:50:35 EDT
I'm currently traveling but will take a look and test this weekend or early next week.
Comment 4 Steve Milner 2010-08-06 15:55:17 EDT
Sorry about the lag on this. I ended up getting sick this week. Any chance you can point me to en EL5 scratch build?
Comment 5 Kevin Fenzi 2010-08-06 17:15:10 EDT
Here's one: 

http://koji.fedoraproject.org/koji/taskinfo?taskID=2386299
Comment 6 Steve Milner 2010-08-09 09:24:01 EDT
Thanks, I'll take a look.
Comment 7 Steve Milner 2010-08-10 14:46:41 EDT
Unfortunately it looks like it gets hit earlier than Spawning due to a missing dependency on pyOpenSSL.

[steve@maltus ~]$ spawning 
Traceback (most recent call last):
  File "/usr/lib/python2.4/site-packages/eventlet/__init__.py", line 10, in ?
    from eventlet import convenience
  File "/usr/lib/python2.4/site-packages/eventlet/convenience.py", line 130, in ?
    from eventlet.green.OpenSSL import SSL
  File "/usr/lib/python2.4/site-packages/eventlet/green/OpenSSL/__init__.py", line 1, in ?
    import rand, crypto, SSL, tsafe
  File "/usr/lib/python2.4/site-packages/eventlet/green/OpenSSL/rand.py", line 1, in ?
    from OpenSSL.rand import *
ImportError: No module named OpenSSL.rand
Traceback (most recent call last):
  File "/usr/bin/spawning", line 7, in ?
    sys.exit(
  File "/usr/lib/python2.4/site-packages/pkg_resources.py", line 236, in load_entry_point
    return get_distribution(dist).load_entry_point(group, name)
  File "/usr/lib/python2.4/site-packages/pkg_resources.py", line 2097, in load_entry_point
    return ep.load()
  File "/usr/lib/python2.4/site-packages/pkg_resources.py", line 1830, in load
    entry = __import__(self.module_name, globals(),globals(), ['__name__'])
  File "/usr/lib/python2.4/site-packages/spawning/spawning_controller.py", line 41, in ?
    from eventlet import api
  File "/usr/lib/python2.4/site-packages/eventlet/api.py", line 13, in ?
    from eventlet import Timeout
ImportError: cannot import name Timeout


After installing pyOpenSSL things seem to work fine. I see lots of DeprecationWarning's but that is nothing new. I tested a few simple Django apps with it and I didn't see any issues.

Does this answer your question?
Comment 8 Steve Milner 2010-09-07 18:40:41 EDT
FYI, the updated version of Spawning requires eventlet-0.9.12 or greater. I will open up a new bug requesting an upgrade.

Please let me know if the above responses answered your question so I may close the bug.
Comment 9 Fedora Update System 2010-09-08 10:14:36 EDT
python-eventlet-0.9.12-2.el5 has been submitted as an update for Fedora EPEL 5.
https://admin.fedoraproject.org/updates/python-eventlet-0.9.12-2.el5
Comment 10 Fedora Update System 2010-09-08 12:27:50 EDT
python-eventlet-0.9.12-2.el5 has been pushed to the Fedora EPEL 5 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update python-eventlet'.  You can provide feedback for this update here: https://admin.fedoraproject.org/updates/python-eventlet-0.9.12-2.el5
Comment 11 Fedora Update System 2010-09-24 13:38:24 EDT
python-eventlet-0.9.12-2.el5 has been pushed to the Fedora EPEL 5 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.