Bug 619751 - mount of nfs4-share fails if portmap does not run with misleading error-message
mount of nfs4-share fails if portmap does not run with misleading error-message
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: nfs-utils (Show other bugs)
5.2
All Linux
low Severity high
: rc
: ---
Assigned To: Steve Dickson
yanfu,wang
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-07-30 08:43 EDT by Gerrit Slomma
Modified: 2014-02-05 16:47 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-02-05 16:47:35 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Gerrit Slomma 2010-07-30 08:43:23 EDT
Description of problem:

If portmap is not running the attempt to mount an nfs4-share fails with the error-message "Cannot allocate memory".

Version-Release number of selected component (if applicable):

util-linux-2.13-0.47.el5
portmap-4.0-65.2.2.1

How reproducible:

everytime when one tries to mount an nfs4 share and portmap does not run.

Steps to Reproduce:
1. try to mount an nfs4 share (mount -v -t nfs4 -o "sec=sys" ${host}:/${share}
2. waith 105 seconds
3. obtain errormessage on console
4. error message in /var/log/kern is a hint
  
Actual results:

# mount -v /logvol/share
Warning: rpc.gssd appears not to be running.
mount: pinging: prog 100003 vers 4 prot tcp port 2049
mount.nfs4: Cannot allocate memory

the share is not mounted, however in /var/log/kern is a hint what is really going on...

tail -f /var/log/kern

Jul 30 13:56:12 B0137160 kernel: portmap: server localhost not responding, timed out
Jul 30 13:56:12 B0137160 kernel: RPC: failed to contact portmap (errno -5).

/etc/init.d/portmap start "repaired" the issue

Expected results:

a better hint on the console when invoking the mount-command

Additional info:

could not test any newer RHEL-release since this is the inhouse-standard, but should apply also.
Comment 1 RHEL Product and Program Management 2014-01-29 05:38:44 EST
This request was evaluated by Red Hat Product Management for inclusion
in a Red Hat Enterprise Linux release.  Product Management has
requested further review of this request by Red Hat Engineering, for
potential inclusion in a Red Hat Enterprise Linux release for currently
deployed products.  This request is not yet committed for inclusion in
a release.
Comment 2 RHEL Product and Program Management 2014-02-05 16:47:35 EST
Development Management has reviewed and declined this request.
You may appeal this decision by reopening this request.

Note You need to log in before you can comment on or make changes to this bug.