Bug 619768 - Inventory host APP ERROR
Inventory host APP ERROR
Status: CLOSED NOTABUG
Product: Red Hat Enterprise MRG
Classification: Red Hat
Component: cumin (Show other bugs)
Development
All Linux
high Severity medium
: 1.3
: ---
Assigned To: Justin Ross
Jan Sarenik
:
Depends On: 622522 623189 623193 623197
Blocks:
  Show dependency treegraph
 
Reported: 2010-07-30 09:33 EDT by Jan Sarenik
Modified: 2010-09-16 07:10 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-09-16 07:10:34 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
APPLICATION ERROR (4.76 KB, text/plain)
2010-07-30 09:33 EDT, Jan Sarenik
no flags Details

  None (edit)
Description Jan Sarenik 2010-07-30 09:33:26 EDT
Created attachment 435557 [details]
APPLICATION ERROR

Cumin is set up and sesame is running. I can see the machine
in Inventory tab. Now I do 'service sesame restart' and after
a while, another entry in Inventory tab appears. I click on
the first of them (most-top), wait a while and refresh the
page until I get APPLICATION ERROR. When I get back to the
Inventory tab after this, I notice there is already only one
entry.

cumin-0.1.4145-1.el5
sesame-0.7.3918-6.el5

How reproducible: 100%

Actual results: APPLICATION ERROR
Expected results: After restart of sesame, the records should be
added to the previous instance.
Comment 1 Justin Ross 2010-08-09 11:31:20 EDT
I've created a distinct bug to address app error prettiness: bz622506.

The problem is that the sesame agent id is unstable, causing mint to think that each new sesame agent lifecycle is a new agent altogether.  I checked the code, and it's not calling setName for the agent id.

I propose that setName be called, and for the id value, I suggest using /var/lib/dbus/machine-id, as suggested at the bottom of http://0pointer.de/blog/projects/ids.html .
Comment 2 Jan Sarenik 2010-08-11 11:55:19 EDT
This bug is ill-described, I apologize for that.
Having split the real problem into peaces with
Justin's help, I am adding those bugs as dependencies.
Comment 3 Justin Ross 2010-09-16 07:10:34 EDT
All child bugs are modified now.  As this ended up being just a tracker bug, closing it.

Note You need to log in before you can comment on or make changes to this bug.