Bug 61983 - lastlogin has problems if extremely high uid's present
lastlogin has problems if extremely high uid's present
Status: CLOSED RAWHIDE
Product: Red Hat Public Beta
Classification: Retired
Component: shadow-utils (Show other bugs)
skipjack-beta1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Nalin Dahyabhai
David Lawrence
:
Depends On:
Blocks: 61901
  Show dependency treegraph
 
Reported: 2002-03-26 11:02 EST by panu.matilainen
Modified: 2007-04-18 12:41 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-03-26 15:09:31 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description panu.matilainen 2002-03-26 11:02:43 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.1.3 (X11; Linux i686; U;) Gecko/20020205

Description of problem:
In presence of extremely high UID's (like > 1000000) in the system lastlog fails
with "File too big" because it's not using the 64bit interface to file operations.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. add user with an UID > 1000000, set password
2. login as that user from console 
3. run 'lastlog'
	

Actual Results:  [pmatilai@godzilla SOURCES]$ lastlog
/var/log/lastlog: File too large

Expected Results:  The usual lastlog-listing ... obviously :)

Additional info:

It should be made to use the 64bit file interface. Adding "-D_LARGEFILE_SOURCE
-D_LARGEFILE64_SOURCE -D_FILE_OFFSET_BITS=64" to src/Makefile and recompile
fixes this but I didn't look at how to get that done from the spec-file.

In addition there's a very similar bug in 'sessreg' - see
https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=42850

And BTW this problem is also present on RHL 7.1 % 7.2...
Comment 1 Nalin Dahyabhai 2002-03-27 20:45:38 EST
The necessary changes will be added to shadow-utils-20000902-7 and later.  Thanks!

Note You need to log in before you can comment on or make changes to this bug.