Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 619894 - customized settings are not remembered if first attempt fails to create VM
customized settings are not remembered if first attempt fails to create VM
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: virt-manager (Show other bugs)
6.0
All Linux
low Severity medium
: rc
: ---
Assigned To: Cole Robinson
Virtualization Bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-07-30 15:44 EDT by Eric Blake
Modified: 2011-05-19 09:46 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-05-19 09:46:39 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2011:0637 normal SHIPPED_LIVE virt-manager bug fix and enhancement update 2011-05-18 13:55:47 EDT

  None (edit)
Description Eric Blake 2010-07-30 15:44:02 EDT
Description of problem:
I tried to use virt-manager to create a new VM with storage located on NFS.  I also customized the settings (to select vga instead of cirrus for the video adapter).  The first attempt failed, because of SELinux, so I backed up a screen, fixed the selinux settings, then went forward again, but my customizations were lost and I had to repeat them.

Version-Release number of selected component (if applicable):
virt-manager-0.8.4-7.el6.noarch


How reproducible:
always

Steps to Reproduce:
1. as root, run setsebool virt_use_nfs 0
2. Start virt-manager, and connect to a host
3. Start to create a new domain
4. On step 4, select managed storage, and select a disk image on an NFS path
5. On step 5, check Customize before hitting finish
6. Make a customization, such as changing video to vga, and apply, then hit the check mark to start the install
7. The install will fail because the image can't be accessed and kick you back to step 5
8. run setsebool virt_use_nfs 1
9. Again, check customize, and notice that the customization was lost
  
Actual results:
customization is lost every time that creation fails and you get kicked back to step 5

Expected results:
customization should be remembered - if creation fails, and I correct the root cause of the failure, then continuing from step 5 should remember what I already changed

Additional info:
Comment 1 Eric Blake 2010-07-30 15:44:44 EDT
Not a show-stopper for 6.0.
Comment 2 Cole Robinson 2010-12-07 17:10:01 EST
Fixed upstream now with a combination of virt-manager and virtinst commits, though we should get it all for 'free' with the rebase.
Comment 3 Cole Robinson 2011-01-14 17:16:31 EST
Fixed in virt-manager-0.8.6-1.el6
Comment 5 min zhan 2011-01-17 07:29:39 EST
Now customization can be remembered and installation is going well. So verified with passed in virt-manager-0.8.6-1.el6

# uname -a
Linux dhcp-65-85.nay.redhat.com 2.6.32-99.el6.x86_64 #1 SMP Fri Jan 14 10:46:00
EST 2011 x86_64 x86_64 x86_64 GNU/Linux

kernel-2.6.32-99.el6.x86_64
qemu-kvm-0.12.1.2-2.129.el6.x86_64
libvirt-0.8.7-1.el6.x86_64
Comment 6 errata-xmlrpc 2011-05-19 09:46:39 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2011-0637.html

Note You need to log in before you can comment on or make changes to this bug.