Bug 619922 - systemd makes a text console unusable
Summary: systemd makes a text console unusable
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: systemd (Show other bugs)
(Show other bugs)
Version: rawhide
Hardware: All Linux
low
medium
Target Milestone: ---
Assignee: Lennart Poettering
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-07-30 21:36 UTC by Michal Jaegermann
Modified: 2010-08-10 02:44 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-08-10 01:46:04 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Michal Jaegermann 2010-07-30 21:36:26 UTC
Description of problem:

After a boot to runlevel 3 (with fixes to bug #618315 already applied) there is no echo of typed characters.  Login over a network and killing 'login' process "fixes" that to some extent, i.e. echoing returns, but now it turns out that keystrokes are accepted or not in an apparently random manner.  Sometimes they have to be doubled before they "take", sometimes not and sometimes a line terminator shows up "by itself". Due to these interesting properties chances of getting at least some resemblance of a working console without a network connection are rather meagre.  With an initial login keystrokes are accepted "in blind", i.e. without echo, but no way to predict what reached the system.

After booting with "... 3 init=/sbin/upstart" both login and console behave as they should.

Version-Release number of selected component (if applicable):
systemd-4-4.fc14

Additional information:
I did not notice instances when more that two repeats of a keystroke were required to send a given character; only that sometimes one hit is enough and sometimes not.

Comment 1 Michal Schmidt 2010-08-01 08:12:55 UTC
Does it happen on tty1 only or are other VTs affected too? (Try ALT+F<n>)

Comment 2 Michal Jaegermann 2010-08-01 14:15:08 UTC
(In reply to comment #1)
> Does it happen on tty1 only or are other VTs affected too? (Try ALT+F<n>)    

Good call!  There is an echo on other VTs from the start and typed characters are lost very infrequently (it still happens sporadically).

Killing mgetty on tty1 does restore echo there but does nothing to make a keyboard sane.  Even switching to another console may require mulitiple keyboard hits and may stall for a while.

Comment 3 Michal Schmidt 2010-08-01 16:08:55 UTC
The problem is that in multi-user.target nothing tells plymouth to quit.
In upstart it was done by /etc/init/quit-plymouth.conf which calls "/usr/bin/plymouth quit".

Comment 4 Lennart Poettering 2010-08-10 01:46:04 UTC
Fixed now upstream. Upload to F14 follows shortly.

Comment 5 Mamoru TASAKA 2010-08-10 02:44:32 UTC
%post scriptlet of systemd-units still says
-----------------------------------------
111 %post units
112 if [ $1 -eq 1 ] ; then
-----------------------------------------

So do we again have to $ rpm -e --nodeps systemd-units and
reinstall systemd-units, not by just update?


Note You need to log in before you can comment on or make changes to this bug.