Bug 619934 - systemd boot ignores dynamically assigned system names
Summary: systemd boot ignores dynamically assigned system names
Status: CLOSED DUPLICATE of bug 615293
Alias: None
Product: Fedora
Classification: Fedora
Component: systemd (Show other bugs)
(Show other bugs)
Version: rawhide
Hardware: All Linux
low
medium
Target Milestone: ---
Assignee: Lennart Poettering
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-07-30 22:31 UTC by Michal Jaegermann
Modified: 2010-08-03 20:53 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-08-03 20:53:15 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Michal Jaegermann 2010-07-30 22:31:14 UTC
Description of problem:

Systems may get their names dynamically assigned depending on an IP address received via DHCP.  Unfortunately NetworkManager appears unable to handle
that (see bug 441453) so in an environment which needs such things one runs a service "network" instead which does not have this problem.

It appears that systemd ignores such configuration and one ends up always with 'localhost.localdomain' for a machine name thus recreating bug 441453. It is possible that this situation is related to bug 619931.

After boot with "init=/sbin/upstart" machine names are set as expected.

Version-Release number of selected component (if applicable):
systemd-4-4.fc14

Additional info:
Long time ago promissed fixes to NetworkManager and/or gdm failed to materialize.  In any case nothing says that any sort of a graphic login facility may be present.

Comment 1 Michal Schmidt 2010-08-03 07:09:15 UTC
The systemd aspect of this issue is probably a duplicate of bug 615293. You can test it by deleting "$network" from LSB Provides in /etc/init.d/NetworkManager.

That said, if NetworkManager is still causing trouble with the hostname, the BZ about it should be reopened.

Comment 2 Michal Jaegermann 2010-08-03 20:53:15 UTC
(In reply to comment #1)
> The systemd aspect of this issue is probably a duplicate of bug 615293. You can
> test it by deleting "$network" from LSB Provides in /etc/init.d/NetworkManager.

You are correct.  After deleting "$network" from Provides a machine name is assigned as expected.  Also NetworkManager and wpa_supplicant do not start while configured "off".  I guess that this means that I can close this as a duplicate.

*** This bug has been marked as a duplicate of bug 615293 ***


Note You need to log in before you can comment on or make changes to this bug.