Bug 619944 - Shotwell doesn't regenerate its thumbnails
Summary: Shotwell doesn't regenerate its thumbnails
Status: CLOSED CANTFIX
Alias: None
Product: Fedora
Classification: Fedora
Component: shotwell (Show other bugs)
(Show other bugs)
Version: 13
Hardware: All Linux
low
medium
Target Milestone: ---
Assignee: Matthias Clasen
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-07-30 23:18 UTC by Mathieu Bridon
Modified: 2011-03-18 01:00 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-03-18 01:00:12 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
viewing an event and its key photo works fine (135.87 KB, image/png)
2010-07-30 23:18 UTC, Mathieu Bridon
no flags Details
viewing photos does not: photos are invisible but can still be clicked/interacted with (35.48 KB, image/png)
2010-07-30 23:19 UTC, Mathieu Bridon
no flags Details

Description Mathieu Bridon 2010-07-30 23:18:55 UTC
Created attachment 435696 [details]
viewing an event and its key photo works fine

Description of problem:
When I first tried it, Shotwell was working perfectly, and so I imported all my photos in it.

But a few days ago I noticed something is not right: when viewing *any* event, photos in that event are invisible. This is also the case when I try to view all photos with the « Photos » top-left button.

Now the photos are actually there, since I can select them (I see the blue rectangle around them when I blindly left-click on a photo), and I can even display them by blindly double-clicking on a photo.

But other than that, all I see is the gray background (see screnshot).

However, the rest of the application works as expected, I can view events (the key photo is displayed, see screenshot), I can (blindly) rotate photos, etc.


Version-Release number of selected component (if applicable):
shotwell-0.5.2-1.fc13.x86_64


How reproducible:
Always, just launch shotwell and try to view some photos.


Additional info:
At first I thought it was an incompatibility between Shotwell and Gnome-Shell, but now I'm back on stock Fedora Metacity+Gnome-Panel, and still have the same behavior.

Comment 1 Mathieu Bridon 2010-07-30 23:19:52 UTC
Created attachment 435697 [details]
viewing photos does not: photos are invisible but can still be clicked/interacted with

Comment 2 Mathieu Bridon 2010-08-05 16:47:17 UTC
I just imported some new photos in Shotwell, and those are all visible.

The ones that were already imported remain invisible though.

I tried closing and reopening Shotwell, those new photos are still visible.

Looking closer, some photos that had been previously imported are still visible, so to sum it up, when I opened the bug report I had imported a total of 2283 photos, only 3 of them are still visible now. The 14 new ones I imported today are visible as well.

I can't find anything that would make some visible and others invisible. :-/

Comment 3 Mathieu Bridon 2010-10-02 22:50:49 UTC
I tried to remove the .shotwell/thumbs/thumbs{128,360} folders, thinking Shotwell would recreate the thumbnails at next startup, but it didn't.

Now, absolutely all the photos are « invisible », even the ones that I could see in comment #2.

Apparently, Shotwell only creates thumbnails at import time, but it doesn't regenerate them afterwards if needed.

It seems to be a known bug upstream. I couldn't find any bug specifically related to it, but the devs seem to be aware of it:
"""
Shotwell is *not* yet smart enough to regenerate its thumbnails automatically if those are deleted, so I think that Shotwell's thumbnails should live in the XDG data directory.
"""
  -> http://trac.yorba.org/ticket/421#comment:8

Comment 4 Michel Alexandre Salim 2011-03-18 01:00:12 UTC
Unfortunately we can't update F-13's shotwell, so even if upstream releases a fix, it won't help F-13 users. I've just issued an update for F-14, bringing it to 0.8.1, and the upcoming F-15 will have 0.9.0.

Unfortunately F-13 is stuck in the 0.5.x series, and F-14 in 0.8.x, due to major Vala changes in each. 0.9.0 pre-releases only compile with the Vala release from yesterday!

I'd recommend moving to F-14 if at all possible.


Note You need to log in before you can comment on or make changes to this bug.