This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 619945 - blueman needs to be rebuilt against python 2.7 in F14 and devel
blueman needs to be rebuilt against python 2.7 in F14 and devel
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: blueman (Show other bugs)
14
All Linux
low Severity urgent
: ---
: ---
Assigned To: Orcan Ogetbil
Fedora Extras Quality Assurance
AcceptedBlocker
:
Depends On:
Blocks: F14Alpha/F14AlphaBlocker Python27Rebuild
  Show dependency treegraph
 
Reported: 2010-07-30 19:19 EDT by Adam Williamson
Modified: 2010-08-01 16:30 EDT (History)
3 users (show)

See Also:
Fixed In Version: blueman-1.21-6.fc14
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-08-01 16:30:55 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Adam Williamson 2010-07-30 19:19:13 EDT
The package needs to be rebuilt against python 2.7 in both F14 and devel.

Information on the new "dist-git" system can be seen here:
  http://fedoraproject.org/wiki/Using_Fedora_GIT

Information on common difficulties with Python 2.7 rebuilds can be seen here:
  https://fedoraproject.org/wiki/Features/Python_2.7

Once it's been successfully rebuilt for F14, an update needs to be filed to get the rebuild into F14:
  https://admin.fedoraproject.org/updates/new/

Please add this bug to the update, to make it easy to track what's been done, and what's left to do.

Thanks!

This rebuild is critical as it affects the composing of DVD images for
the Alpha release, so it must be sorted out by Tuesday 2010-08-02 or the Alpha
will slip.
Comment 1 Adam Williamson 2010-07-30 19:44:14 EDT
Blocks Alpha.



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 2 Dave Malcolm 2010-07-31 05:02:02 EDT
Fails to build from source:
http://koji.fedoraproject.org/koji/taskinfo?taskID=2368451
BuildError: Error running GIT checkout command "git clone -n git://pkgs.fedoraproject.org/Blueman Blueman", see checkout.log for details

Renamed Blueman.spec -> blueman.spec in f14 and master in dist-git:

* Sat Jul 31 2010 David Malcolm <dmalcolm@redhat.com> - 1.21-6
- fix capitalization of specfile name

Building into dist-rawhide:
http://koji.fedoraproject.org/koji/taskinfo?taskID=2368461

Building into dist-f14:
http://koji.fedoraproject.org/koji/taskinfo?taskID=2368455
Comment 3 Dave Malcolm 2010-07-31 05:04:39 EDT
Build failed, looks like a circular build dependency (old blueman required to build); one of the build dependencies presumably has a requirement on blueman itself.
Comment 4 Dave Malcolm 2010-07-31 22:29:29 EDT
oget managed to build this, and filed this update:
  https://admin.fedoraproject.org/updates/blueman-1.21-6.fc14
(though this bug is not attached to it)
Comment 5 Orcan Ogetbil 2010-08-01 16:30:55 EDT
The fixed package is built an pushed to stable.

Note You need to log in before you can comment on or make changes to this bug.