Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 619976 - python-storm fails its test suite on python-2.7
python-storm fails its test suite on python-2.7
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: python-storm (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Michel Alexandre Salim
Fedora Extras Quality Assurance
:
Depends On:
Blocks: Python27Rebuild
  Show dependency treegraph
 
Reported: 2010-07-30 23:08 EDT by Toshio Ernie Kuratomi
Modified: 2011-03-29 12:21 EDT (History)
1 user (show)

See Also:
Fixed In Version: python-storm-0.18-1.el6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-03-19 01:48:08 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
fix ordering assumption in test suite (705 bytes, patch)
2010-07-30 23:12 EDT, Toshio Ernie Kuratomi
no flags Details | Diff


External Trackers
Tracker ID Priority Status Summary Last Updated
Launchpad 641326 None None None Never

  None (edit)
Description Toshio Ernie Kuratomi 2010-07-30 23:08:48 EDT
Description of problem:
a unittest fails when rebuilding with python-2.7.  Looks like the ordering inside of a cache is not stable but storm's test suite doesn't recognize that.

I'm fixing the test suite with the attached patch and rebuilding for f15 and f14.  Please submit the patch upstream.
Comment 1 Toshio Ernie Kuratomi 2010-07-30 23:12:26 EDT
Created attachment 435718 [details]
fix ordering assumption in test suite
Comment 2 Michel Alexandre Salim 2010-09-17 10:04:50 EDT
Reported; leaving this open until upstream makes a decision.
Comment 3 Fedora Update System 2011-03-13 15:03:44 EDT
python-storm-0.18-1.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/python-storm-0.18-1.fc14
Comment 4 Fedora Update System 2011-03-13 15:03:56 EDT
python-storm-0.18-1.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/python-storm-0.18-1.fc15
Comment 5 Fedora Update System 2011-03-13 15:04:08 EDT
python-storm-0.18-1.fc13 has been submitted as an update for Fedora 13.
https://admin.fedoraproject.org/updates/python-storm-0.18-1.fc13
Comment 6 Fedora Update System 2011-03-13 15:04:19 EDT
python-storm-0.18-1.el6 has been submitted as an update for Fedora EPEL 6.
https://admin.fedoraproject.org/updates/python-storm-0.18-1.el6
Comment 7 Fedora Update System 2011-03-19 01:47:58 EDT
python-storm-0.18-1.fc15 has been pushed to the Fedora 15 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 8 Fedora Update System 2011-03-22 14:53:24 EDT
python-storm-0.18-1.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 9 Fedora Update System 2011-03-22 14:53:47 EDT
python-storm-0.18-1.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 10 Fedora Update System 2011-03-29 12:21:31 EDT
python-storm-0.18-1.el6 has been pushed to the Fedora EPEL 6 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.