Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 619984 - [RFE] Full beaker support when taking machine via WebUI
[RFE] Full beaker support when taking machine via WebUI
Status: CLOSED NOTABUG
Product: Beaker
Classification: Community
Component: lab controller (Show other bugs)
0.5
All Linux
medium Severity medium (vote)
: future_maint
: ---
Assigned To: Bill Peck
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-07-31 02:53 EDT by Eryu Guan
Modified: 2012-09-27 20:48 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-09-27 20:48:44 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Eryu Guan 2010-07-31 02:53:53 EDT
Description of problem:
When taking machine via WebUI, there's no beaker environment installed, one have to install beaker repo, beaker task repo and beakerlib etc. manually.

But all this is done when reserving machine via reserve-workflow. One just do yum install rh-tests-some-tests, no need to prepare beaker environment.

Version-Release number of selected component (if applicable):
0.5.51
Comment 1 Dan Callaghan 2012-09-27 20:48:44 EDT
Beaker intentionally treats manual provisioning (systems set to "Manual") differently to provisioning through the scheduler (systems set to "Automated"). So this is a feature, not a bug :-)

If you need all the scheduler-related support to be installed on the system, use the reserve workflow.

Note You need to log in before you can comment on or make changes to this bug.