Bug 620015 - python-wokkel needs to be rebuilt against python 2.7 in F14 and devel
Summary: python-wokkel needs to be rebuilt against python 2.7 in F14 and devel
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: python-wokkel   
(Show other bugs)
Version: 14
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Ruben Kerkhof
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: Python27Rebuild
TreeView+ depends on / blocked
 
Reported: 2010-07-31 11:58 UTC by Dave Malcolm
Modified: 2010-08-01 19:18 UTC (History)
1 user (show)

Fixed In Version: python-wokkel-0.6.3-4.fc14
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-08-01 19:18:08 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Dave Malcolm 2010-07-31 11:58:37 UTC
The package needs to be rebuilt against python 2.7 in both F14 and devel.

Information on the new "dist-git" system can be seen here:
  http://fedoraproject.org/wiki/Using_Fedora_GIT

Information on common difficulties with Python 2.7 rebuilds can be seen here:
  https://fedoraproject.org/wiki/Features/Python_2.7

Once it's been successfully rebuilt for F14, an update needs to be filed to get the rebuild into F14:
  https://admin.fedoraproject.org/updates/new/

Please add this bug to the update, to make it easy to track what's been done, and what's left to do.

Thanks!

Comment 1 Dave Malcolm 2010-07-31 11:59:20 UTC
http://koji.fedoraproject.org/koji/getfile?taskID=2368698&name=build.log

Some of the tests are failing:
===============================================================================
[ERROR]: wokkel.test.test_server.XMPPServerListenAuthenticatorTest.test_onResultFailure
Traceback (most recent call last):
  File "/builddir/build/BUILD/wokkel-0.6.3/wokkel/test/test_server.py", line 292, in cb
    self.assertEqual(1, len(self.flushLoggedErrors(TestError)))
  File "/usr/lib/python2.7/site-packages/twisted/trial/unittest.py", line 999, in flushLoggedErrors
    return self._observer.flushErrors(*errorTypes)
exceptions.AttributeError: 'XMPPServerListenAuthenticatorTest' object has no attribute '_observer'
===============================================================================
[ERROR]: wokkel.test.test_server.XMPPServerListenAuthenticatorTest.test_onResultFailure
Traceback (most recent call last):
Failure: wokkel.test.test_server.TestError: 
===============================================================================
[ERROR]: wokkel.test.test_subprotocols.IQHandlerTest.test_failureUnknown
Traceback (most recent call last):
  File "/builddir/build/BUILD/wokkel-0.6.3/wokkel/test/test_subprotocols.py", line 541, in test_failureUnknown
    self.assertEquals(1, len(self.flushLoggedErrors(TestError)))
  File "/usr/lib/python2.7/site-packages/twisted/trial/unittest.py", line 999, in flushLoggedErrors
    return self._observer.flushErrors(*errorTypes)
exceptions.AttributeError: 'IQHandlerTest' object has no attribute '_observer'
===============================================================================
[ERROR]: wokkel.test.test_subprotocols.IQHandlerTest.test_failureUnknown
Traceback (most recent call last):
  File "/usr/lib/python2.7/site-packages/twisted/internet/defer.py", line 106, in maybeDeferred
    result = f(*args, **kw)
  File "/builddir/build/BUILD/wokkel-0.6.3/wokkel/test/test_subprotocols.py", line 528, in onGet
    raise TestError()
wokkel.test.test_subprotocols.TestError: 
-------------------------------------------------------------------------------
Ran 344 tests in 0.968s
FAILED (errors=4, successes=342)

Comment 2 Dave Malcolm 2010-07-31 12:17:40 UTC
The "object has no attribute '_observer'" failures look like the problem is in twisted.trial (part of python-twisted-core in Fedora).

Comment 3 Ruben Kerkhof 2010-07-31 13:47:38 UTC
Hi Dave,

I've checked in a patch into rawhide which runs the unittest with python instead of trial. I'm unable to kick off a build though and haven't figured out yet how to fix it:

[ruben@slice python-wokkel]$ fedpkg build
Traceback (most recent call last):
  File "/usr/bin/fedpkg", line 959, in <module>
    args.command(args)
  File "/usr/bin/fedpkg", line 297, in build
    mymodule.init_koji(args.user, kojiconfig)
  File "/usr/lib/python2.7/site-packages/pyfedpkg/__init__.py", line 1102, in init_koji
    defaults['serverca'])
  File "/usr/lib/python2.7/site-packages/koji/__init__.py", line 1628, in ssl_login
    sinfo = self.callMethod('sslLogin', proxyuser)
  File "/usr/lib/python2.7/site-packages/koji/__init__.py", line 1673, in callMethod
    return self._callMethod(name, args, opts)
  File "/usr/lib/python2.7/site-packages/koji/__init__.py", line 1698, in _callMethod
    return proxy.__getattr__(name)(*args)
  File "/usr/lib64/python2.7/xmlrpclib.py", line 1224, in __call__
    return self.__send(self.__name, args)
  File "/usr/lib64/python2.7/xmlrpclib.py", line 1570, in __request
    verbose=self.__verbose
  File "/usr/lib64/python2.7/xmlrpclib.py", line 1264, in request
    return self.single_request(host, handler, request_body, verbose)
  File "/usr/lib64/python2.7/xmlrpclib.py", line 1294, in single_request
    response = h.getresponse(buffering=True)
AttributeError: PlgHTTPS instance has no attribute 'getresponse'


Would you be so kind to do a build yourself?

Comment 5 Dave Malcolm 2010-07-31 22:36:29 UTC
Looks like Toshio already rebuilt these from git; the above builds failed with "Build already exists" errors.

Comment 6 Dave Malcolm 2010-07-31 22:38:06 UTC
https://admin.fedoraproject.org/updates/python-wokkel-0.6.3-4.fc14 filed (though not yet linked to this bug)

Comment 7 Fedora Update System 2010-07-31 22:54:37 UTC
python-wokkel-0.6.3-4.fc14 has been submitted as an update for Fedora 14.
http://admin.fedoraproject.org/updates/python-wokkel-0.6.3-4.fc14

Comment 8 Fedora Update System 2010-08-01 19:18:04 UTC
python-wokkel-0.6.3-4.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.