Bug 620019 - python-peak-rules needs to be rebuilt against python 2.7 in F14 and devel
python-peak-rules needs to be rebuilt against python 2.7 in F14 and devel
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: python-peak-rules (Show other bugs)
14
All Linux
low Severity medium
: ---
: ---
Assigned To: Luke Macken
Fedora Extras Quality Assurance
:
Depends On: 620023
Blocks: Python27Rebuild 620192 620193
  Show dependency treegraph
 
Reported: 2010-07-31 08:46 EDT by Dave Malcolm
Modified: 2016-09-19 22:41 EDT (History)
4 users (show)

See Also:
Fixed In Version: python-peak-rules-0.5a1.dev-12.a1.dev.20100803svn2646.fc14
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-08-05 10:28:05 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dave Malcolm 2010-07-31 08:46:09 EDT
The package needs to be rebuilt against python 2.7 in both F14 and devel.

Automated rebuild failed; the issue appears to be in python-peak-util-assembler:
  File "/usr/lib/python2.7/site-packages/peak/util/assembler.py", line 221, in TryExcept
    next_test.JUMP_IF_FALSE, Code.POP_TOP,      # remove condition
AttributeError: 'Label' object has no attribute 'JUMP_IF_FALSE'

http://koji.fedoraproject.org/koji/getfile?taskID=2368743&name=build.log


Information on the new "dist-git" system can be seen here:
  http://fedoraproject.org/wiki/Using_Fedora_GIT

Information on common difficulties with Python 2.7 rebuilds can be seen here:
  https://fedoraproject.org/wiki/Features/Python_2.7

Once it's been successfully rebuilt for F14, an update needs to be filed to get the rebuild into F14:
  https://admin.fedoraproject.org/updates/new/

Please add this bug to the update, to make it easy to track what's been done, and what's left to do.

Thanks!
Comment 1 Dave Malcolm 2010-07-31 08:49:18 EDT
Looks like an underlying bytecode change in python 2.7 that needs fixing in python-peak-util-assembler:

Python 2.6.5 (r265:79063, Jul 13 2010, 21:20:31) 
[GCC 4.4.3 20100127 (Red Hat 4.4.3-4)] on linux2
Type "help", "copyright", "credits" or "license" for more information.
>>> import dis
>>> 'JUMP_IF_FALSE' in dis.opname
True


Python 2.7 (r27:82500, Jul 28 2010, 18:07:57) 
[GCC 4.5.0 20100716 (Red Hat 4.5.0-3)] on linux2
Type "help", "copyright", "credits" or "license" for more information.
>>> import dis
>>> 'JUMP_IF_FALSE' in dis.opname
False
Comment 2 Dave Malcolm 2010-07-31 08:52:09 EDT
This appears to have been this bytecode change in 2.7:
http://svn.python.org/view?view=rev&revision=70071
Comment 3 Dave Malcolm 2010-07-31 09:57:13 EDT
I've opened bug 620023 to track the underlying issue.
Comment 4 Toshio Ernie Kuratomi 2010-08-03 08:47:26 EDT
python-peak-util-assembler updated.  Build override requested for f14.

I've checked in and pushed updated sources for building this package but the patches need to be ported or discarded.  Please feel free to do that as I must fall into bed now.
Comment 5 Fedora Update System 2010-08-03 16:12:37 EDT
python-peak-rules-0.5a1.dev-12.a1.dev.20100803svn2646.fc14 has been submitted as an update for Fedora 14.
http://admin.fedoraproject.org/updates/python-peak-rules-0.5a1.dev-12.a1.dev.20100803svn2646.fc14
Comment 6 Fedora Update System 2010-08-05 10:28:01 EDT
python-peak-rules-0.5a1.dev-12.a1.dev.20100803svn2646.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.