Bug 620021 - libdesktop-agnostic needs to be rebuilt against python 2.7 in F14 and devel
libdesktop-agnostic needs to be rebuilt against python 2.7 in F14 and devel
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: libdesktop-agnostic (Show other bugs)
14
All Linux
low Severity medium
: ---
: ---
Assigned To: Orcan Ogetbil
Fedora Extras Quality Assurance
:
Depends On:
Blocks: Python27Rebuild
  Show dependency treegraph
 
Reported: 2010-07-31 08:48 EDT by Thomas Spura
Modified: 2010-08-01 16:34 EDT (History)
2 users (show)

See Also:
Fixed In Version: libdesktop-agnostic-0.3.90-10.fc14
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-08-01 16:34:39 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Thomas Spura 2010-07-31 08:48:47 EDT
The package needs to be rebuilt against python 2.7 in both F14 and devel.

Information on the new "dist-git" system can be seen here:
  http://fedoraproject.org/wiki/Using_Fedora_GIT

Information on common difficulties with Python 2.7 rebuilds can be seen here:
  https://fedoraproject.org/wiki/Features/Python_2.7

Once it's been successfully rebuilt for F14, an update needs to be filed to get the rebuild into F14:
  https://admin.fedoraproject.org/updates/new/

Please add this bug to the update, to make it easy to track what's been done, and what's left to do.

Thanks!

___________________________________________________________________________

A recent scratch build fails:
http://koji.fedoraproject.org/koji/taskinfo?taskID=2368746

Because of:
default/libdesktop-agnostic/DesktopAgnostic-1.0.gir:3:1: error: Unsupported version '1.0'
error parsing file default/libdesktop-agnostic/DesktopAgnostic-1.0.gir: Unsupported version '1.0'
12:45:45 runner system command ->  LD_LIBRARY_PATH="/builddir/build/BUILD/libdesktop-agnostic-0.3.90/build/default/libdesktop-agnostic" /usr/bin/g-ir-compiler -o default/libdesktop-agnostic/DesktopAgnosticUI-1.0.typelib default/libdesktop-agnostic/DesktopAgnosticUI-1.0.gir 
default/libdesktop-agnostic/DesktopAgnosticConfig-1.0.gir:3:1: error: Unsupported version '1.0'
error parsing file default/libdesktop-agnostic/DesktopAgnosticConfig-1.0.gir: Unsupported version '1.0'
default/libdesktop-agnostic/DesktopAgnosticVFS-1.0.gir:3:1: error: Unsupported version '1.0'
error parsing file default/libdesktop-agnostic/DesktopAgnosticVFS-1.0.gir: Unsupported version '1.0'
default/libdesktop-agnostic/DesktopAgnosticFDO-1.0.gir:3:1: error: Unsupported version '1.0'
error parsing file default/libdesktop-agnostic/DesktopAgnosticFDO-1.0.gir: Unsupported version '1.0'
default/libdesktop-agnostic/DesktopAgnosticUI-1.0.gir:3:1: error: Unsupported version '1.0'
error parsing file default/libdesktop-agnostic/DesktopAgnosticUI-1.0.gir: Unsupported version '1.0'
Waf: Leaving directory `/builddir/build/BUILD/libdesktop-agnostic-0.3.90/build'
Build failed
Comment 1 leigh scott 2010-07-31 09:25:29 EDT
I'm unable to fix the gir version error myself and have reported the issue upstream in the hope that they will fix it.

https://bugs.launchpad.net/libdesktop-agnostic/+bug/609074
Comment 2 Orcan Ogetbil 2010-08-01 16:34:39 EDT
The fixed package is built an pushed to stable.

Note You need to log in before you can comment on or make changes to this bug.