Bug 620033 - SELinux is preventing /usr/sbin/abrtd "fowner" access .
SELinux is preventing /usr/sbin/abrtd "fowner" access .
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
13
i386 Linux
low Severity medium
: ---
: ---
Assigned To: Miroslav Grepl
Fedora Extras Quality Assurance
setroubleshoot_trace_hash:aeb879c46b4...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-07-31 10:25 EDT by John Dulaney
Modified: 2014-06-18 05:06 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-08-03 09:10:46 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description John Dulaney 2010-07-31 10:25:14 EDT
Summary:

SELinux is preventing /usr/sbin/abrtd "fowner" access .

Detailed Description:

SELinux denied access requested by abrtd. It is not expected that this access is
required by abrtd and this access may signal an intrusion attempt. It is also
possible that the specific version or configuration of the application is
causing it to require additional access.

Allowing Access:

You can generate a local policy module to allow this access - see FAQ
(http://docs.fedoraproject.org/selinux-faq-fc5/#id2961385) Please file a bug
report.

Additional Information:

Source Context                system_u:system_r:abrt_t:s0-s0:c0.c1023
Target Context                system_u:system_r:abrt_t:s0-s0:c0.c1023
Target Objects                None [ capability ]
Source                        abrtd
Source Path                   /usr/sbin/abrtd
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           abrt-1.1.1-2.fc13
Target RPM Packages           
Policy RPM                    selinux-policy-3.7.19-41.fc13
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Enforcing
Plugin Name                   catchall
Host Name                     (removed)
Platform                      Linux jdulaney.fedoraproject
                              2.6.33.6-147.2.4.fc13.i686 #1 SMP Fri Jul 23
                              17:27:40 UTC 2010 i686 i686
Alert Count                   1
First Seen                    Sat 31 Jul 2010 06:12:17 AM EDT
Last Seen                     Sat 31 Jul 2010 06:12:17 AM EDT
Local ID                      5c7648b9-28aa-49ae-9e42-f608b0868a75
Line Numbers                  

Raw Audit Messages            

node=jdulaney.fedoraproject type=AVC msg=audit(1280571137.185:9): avc:  denied  { fowner } for  pid=1206 comm="abrtd" capability=3  scontext=system_u:system_r:abrt_t:s0-s0:c0.c1023 tcontext=system_u:system_r:abrt_t:s0-s0:c0.c1023 tclass=capability

node=jdulaney.fedoraproject type=SYSCALL msg=audit(1280571137.185:9): arch=40000003 syscall=15 success=no exit=-1 a0=8064dd5 a1=1ed a2=8064dd5 a3=684c3c items=0 ppid=1205 pid=1206 auid=4294967295 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 tty=(none) ses=4294967295 comm="abrtd" exe="/usr/sbin/abrtd" subj=system_u:system_r:abrt_t:s0-s0:c0.c1023 key=(null)




Additional note:
It should be noted that the abrt daemon, sendmail, and sm-client all failed to start at boot.
Hash String generated from  catchall,abrtd,abrt_t,abrt_t,capability,fowner
audit2allow suggests:

#============= abrt_t ==============
allow abrt_t self:capability fowner;
Comment 1 Miroslav Grepl 2010-08-02 12:45:29 EDT
> It should be noted that the abrt daemon, sendmail, and sm-client all failed to
> start at boot.

Could you udpate your selinux-policy 

# yum update seliunx-policy-targeted

and see if these services still doesn't start.
Comment 2 John Dulaney 2010-08-02 13:11:38 EDT
Today's testing update seems to have fixed it.

Note You need to log in before you can comment on or make changes to this bug.