Bug 620034 - RFE: add flag to fedpkg commit to use "clog" without needing to generate it first
Summary: RFE: add flag to fedpkg commit to use "clog" without needing to generate it f...
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: fedora-packager   
(Show other bugs)
Version: rawhide
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Dennis Gilmore
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-07-31 14:26 UTC by Hans de Goede
Modified: 2013-06-25 03:46 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-06-25 03:46:52 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Hans de Goede 2010-07-31 14:26:48 UTC
Hi,

Currently when I'm done fixing up a package and I've tested my changes locally I do:
fedpkg clog && fed commit -p -F clog && rm clog

It could be nice if I could just write:
fedpkg commit -p -z
Instead

Regards,

Hans

Comment 1 Jesse Keating 2010-07-31 17:03:13 UTC
That's pretty reasonable.  Not sure I like "-z" but I get what you're saying.  I have to poke at clog soon anyway to get rid of the first line it is using since that is redundant info for the most part, I could work on this at the same time.

Comment 3 Dennis Gilmore 2013-06-25 03:46:52 UTC
"fedpkg commit -c" does this and has been around for ages


Note You need to log in before you can comment on or make changes to this bug.