Bug 620067 - vtk needs a rebuild against python-2.7
vtk needs a rebuild against python-2.7
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: vtk (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Axel Thimm
Fedora Extras Quality Assurance
:
Depends On:
Blocks: Python27Rebuild 620068 620172
  Show dependency treegraph
 
Reported: 2010-07-31 14:44 EDT by Toshio Ernie Kuratomi
Modified: 2010-08-01 15:20 EDT (History)
3 users (show)

See Also:
Fixed In Version: vtk-5.6.0-36.fc14
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-08-01 15:20:43 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch taken from atrpms.net build of vtk for EL5 (728 bytes, patch)
2010-07-31 19:20 EDT, Dave Malcolm
no flags Details | Diff

  None (edit)
Description Toshio Ernie Kuratomi 2010-07-31 14:44:54 EDT
Description of problem:

vtk needs to be rebuilt against python-2.7 in devel and F-14.

The python bindings are needed for Mayavi at least.

I could help out with this but at present, the vtk package in cvs/git seems to be missing a patch: vtk-5.6.0-testcxxjavaremove.patch

Pasting some common information about this rebuild since some things have changed in the build system in the last couple days:

Information on the new "dist-git" system can be seen here:
  http://fedoraproject.org/wiki/Using_Fedora_GIT

Information on common difficulties with Python 2.7 rebuilds can be seen here:
  https://fedoraproject.org/wiki/Features/Python_2.7

Once it's been successfully rebuilt for F14, an update needs to be filed to get
the rebuild into F14:
  https://admin.fedoraproject.org/updates/new/

Please add this bug to the update, to make it easy to track what's been done,
and what's left to do.

Thanks!
Comment 1 Dave Malcolm 2010-07-31 19:19:58 EDT
See:
  http://atrpms.net/dist/el5/vtk/vtk-5.6.0-34.src.rpm.html

Patch appears to be present in:
  http://atrpms.net/dist/el5/vtk/vtk-5.6.0-34.src.rpm

Attaching vtk-5.6.0-testcxxjavaremove.patch from that src.rpm
Comment 2 Dave Malcolm 2010-07-31 19:20:46 EDT
Created attachment 435808 [details]
Patch taken from atrpms.net build of vtk for EL5
Comment 3 Dave Malcolm 2010-07-31 20:08:41 EDT
Scratch build with the patch failed:
  http://koji.fedoraproject.org/koji/taskinfo?taskID=2370496
with (as far as I can tell):
-- Could NOT find PythonLibs  (missing:  PYTHON_LIBRARIES PYTHON_INCLUDE_DIRS)
-- Could NOT find PythonLibs  (missing:  PYTHON_LIBRARIES PYTHON_INCLUDE_DIRS)
Comment 4 Dave Malcolm 2010-07-31 20:14:19 EDT
"VTK/CMake/FindPythonLibs.cmake" has:
FOREACH(_CURRENT_VERSION 2.6 2.5 2.4 2.3 2.2 2.1 2.0 1.6 1.5)

Looks like 2.7 needs to be added here.
Comment 5 Orion Poplawski 2010-07-31 22:40:41 EDT
I just checked out vtk to add a patch to fix the find python issue but see that the vtk-5.6.0-testcxxjavaremove.patch seems to have been added to the spec but not checked in to git - or at least it is not in my checkout.  Dave - are you working on this?
Comment 6 Dave Malcolm 2010-08-01 01:08:17 EDT
Yes - successful scratch build here:
http://koji.fedoraproject.org/koji/taskinfo?taskID=2370582

Committed to f14 and building as:
http://koji.fedoraproject.org/koji/taskinfo?taskID=2370757

Committed to master and building for F15 as:
http://koji.fedoraproject.org/koji/taskinfo?taskID=2370761
Comment 8 Fedora Update System 2010-08-01 08:15:56 EDT
vtk-5.6.0-36.fc14 has been submitted as an update for Fedora 14.
http://admin.fedoraproject.org/updates/vtk-5.6.0-36.fc14
Comment 9 Fedora Update System 2010-08-01 15:20:39 EDT
vtk-5.6.0-36.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.