Bug 620082 - Python dependance broken.
Summary: Python dependance broken.
Keywords:
Status: CLOSED WORKSFORME
Alias: None
Product: Fedora
Classification: Fedora
Component: python
Version: 14
Hardware: i686
OS: Linux
low
urgent
Target Milestone: ---
Assignee: Dave Malcolm
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-07-31 19:43 UTC by John Dulaney
Modified: 2014-06-18 09:06 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-08-15 20:32:52 UTC


Attachments (Terms of Use)

Description John Dulaney 2010-07-31 19:43:59 UTC
Description of problem:
On atempting to Yum Update into F14, I get several problems based on python dependancy:

Error: Package: setroubleshoot-2.2.91-1.fc13.i686 (@updates-testing/13)
           Requires: python(abi) = 2.6
           Removing: python-2.6.4-27.fc13.i686 (@updates/13)
           Installing: python-2.7-7.fc14.i686 (fedora)
           Available: python3-3.1.2-12.fc14.i686 (fedora)
Error: Package: gnome-dvb-daemon-0.1.20-1.fc14.i686 (fedora)
           Requires: python(abi) = 2.6
           Removing: python-2.6.4-27.fc13.i686 (@updates/13)
           Installing: python-2.7-7.fc14.i686 (fedora)
           Available: python3-3.1.2-12.fc14.i686 (fedora)
Error: Package: setroubleshoot-server-2.2.91-1.fc13.i686 (@updates-testing/13)
           Requires: python(abi) = 2.6
           Removing: python-2.6.4-27.fc13.i686 (@updates/13)
           Installing: python-2.7-7.fc14.i686 (fedora)
           Available: python3-3.1.2-12.fc14.i686 (fedora)
Error: Package: setroubleshoot-server-2.2.91-1.fc13.i686 (@updates-testing/13)
           Requires: libpython2.6.so.1.0
           Removing: python-libs-2.6.4-27.fc13.i686 (@updates/13)
Error: Package: totem-2.30.2-2.fc14.i686 (fedora)
           Requires: libpython2.6.so.1.0
           Removing: python-libs-2.6.4-27.fc13.i686 (@updates/13)
Error: Package: totem-2.30.2-2.fc14.i686 (updates-testing)
           Requires: libpython2.6.so.1.0
           Removing: python-libs-2.6.4-27.fc13.i686 (@updates/13)
Error: Package: gnome-dvb-daemon-0.1.20-1.fc14.i686 (updates-testing)
           Requires: python(abi) = 2.6
           Removing: python-2.6.4-27.fc13.i686 (@updates/13)
           Installing: python-2.7-7.fc14.i686 (fedora)
           Available: python3-3.1.2-12.fc14.i686 (fedora)


How reproducible:
Every time

Steps to Reproduce:
1.  Use Yum Update to update into F14

  
Actual results:
See above

Expected results:
All dependancies to be resolved.

Comment 1 Dave Malcolm 2010-08-02 15:47:01 UTC
Sorry about this.

The ones reported above should all be fixed now; please can you test and confirm that they're fixed.  Thanks!

(See bug 619913 and
  https://bugzilla.redhat.com/showdependencytree.cgi?id=619913&hide_resolved=1
for the status of what's left to do with the Python 2.6 -> 2.7 rebuild)

Comment 2 Dave Malcolm 2012-08-15 20:32:52 UTC
Closing this bug out.


Note You need to log in before you can comment on or make changes to this bug.