Bug 620092 - policycoreutils needs to be rebuilt against python 2.7 in F14 and devel
Summary: policycoreutils needs to be rebuilt against python 2.7 in F14 and devel
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: policycoreutils
Version: 14
Hardware: All
OS: Linux
low
urgent
Target Milestone: ---
Assignee: Daniel Walsh
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: AcceptedBlocker
Depends On:
Blocks: F14Alpha, F14AlphaBlocker Python27Rebuild
TreeView+ depends on / blocked
 
Reported: 2010-07-31 20:38 UTC by Adam Williamson
Modified: 2010-08-01 19:26 UTC (History)
3 users (show)

Fixed In Version: policycoreutils-2.0.83-10.fc14
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-08-01 19:26:09 UTC


Attachments (Terms of Use)

Description Adam Williamson 2010-07-31 20:38:57 UTC
The package needs to be rebuilt against python 2.7 in both F14 and devel.

Information on the new "dist-git" system can be seen here:
  http://fedoraproject.org/wiki/Using_Fedora_GIT

Information on common difficulties with Python 2.7 rebuilds can be seen here:
  https://fedoraproject.org/wiki/Features/Python_2.7

Once it's been successfully rebuilt for F14, an update needs to be filed to get the rebuild into F14:
  https://admin.fedoraproject.org/updates/new/

Please add this bug to the update, to make it easy to track what's been done, and what's left to do.

Thanks!

This rebuild is critical as it affects the composing of DVD images for
the Alpha release, so it must be sorted out by Tuesday 2010-08-02 or the Alpha
will slip.

This was actually done once, as 2.0.83-5, but 2.0.83-6 and 2.0.83-7 were done in Rawhide before py27 tag was merged into rawhide, so they trumped it. We need another rebuild as 2.0.83-8.

Comment 1 Adam Williamson 2010-07-31 20:39:39 UTC

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers

Comment 2 Dave Malcolm 2010-07-31 22:21:44 UTC
F15: policycoreutils-2.0.83-9.fc15 (http://koji.fedoraproject.org/koji/buildinfo?buildID=187064) appears to have been against python 2.7; this looks OK

However, for F14: within policycoreutils-2.0.83-7.fc14 (http://koji.fedoraproject.org/koji/buildinfo?buildID=186683)

policycoreutils-python-2.0.83-7.fc14.i686.rpm
has "Requires: python(abi) = 2.6" (http://koji.fedoraproject.org/koji/rpminfo?rpmID=2092356)

Comment 3 Dave Malcolm 2010-07-31 22:25:31 UTC
Rebuilding into dist-f14 as 2.0.83-10:

* Sat Jul 31 2010 David Malcolm <dmalcolm@redhat.com> - 2.0.83-10
- rebuild against python 2.7

http://koji.fedoraproject.org/koji/taskinfo?taskID=2370306

Comment 4 Fedora Update System 2010-07-31 22:33:03 UTC
policycoreutils-2.0.83-10.fc14 has been submitted as an update for Fedora 14.
http://admin.fedoraproject.org/updates/policycoreutils-2.0.83-10.fc14

Comment 5 Fedora Update System 2010-08-01 19:26:04 UTC
policycoreutils-2.0.83-10.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.