Bug 620104 - ekg2 needs to be rebuilt against python 2.7 in F14 and devel
Summary: ekg2 needs to be rebuilt against python 2.7 in F14 and devel
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: ekg2 (Show other bugs)
(Show other bugs)
Version: 14
Hardware: All Linux
low
medium
Target Milestone: ---
Assignee: Karol Trzcionka
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
: 623291 (view as bug list)
Depends On: 621698
Blocks: Python27Rebuild
TreeView+ depends on / blocked
 
Reported: 2010-07-31 22:35 UTC by Thomas Spura
Modified: 2010-09-02 03:59 UTC (History)
4 users (show)

Fixed In Version: ekg2-0.2-0.15.rc1.fc14
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-09-02 03:59:55 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Thomas Spura 2010-07-31 22:35:00 UTC
The package needs to be rebuilt against python 2.7 in both F14 and devel.

Looks like a missing gtk header:
http://koji.fedoraproject.org/koji/taskinfo?taskID=2370311
menu.c: In function 'menu_about':
menu.c:169:2: warning: implicit declaration of function 'GTK_OBJECT_FLAGS'
menu.c:169:2: error: lvalue required as left operand of assignment
menu.c: In function 'menu_nickmenu':
menu.c:550:2: warning: implicit declaration of function 'xstrdup'
menu.c:550:11: warning: assignment makes pointer from integer without a cast
menu.c: In function 'menu_canacaccel':
menu.c:1137:2: warning: implicit declaration of function 'GTK_WIDGET_IS_SENSITIVE'
menu.c: In function 'menu_create_main':
menu.c:1531:4: warning: implicit declaration of function 'xstrcasecmp'
menu.c:1485:13: warning: unused variable 'usermenu'
userlistgui.c: In function 'fe_userlist_insert':
userlistgui.c:276:15: warning: unused variable 'str'
userlistgui.c:271:6: warning: unused variable 'do_away'
userlistgui.c: In function 'userlist_click_cb':
userlistgui.c:414:4: warning: implicit declaration of function 'menu_nickmenu'
userlistgui.c: In function 'userlist_create':
userlistgui.c:488:2: warning: #warning "xchat->ekg2: drag & drop"
make[4]: *** [gtk_la-menu.lo] Error 1
make[4]: *** Waiting for unfinished jobs....


Information on the new "dist-git" system can be seen here:
  http://fedoraproject.org/wiki/Using_Fedora_GIT

Information on common difficulties with Python 2.7 rebuilds can be seen here:
  https://fedoraproject.org/wiki/Features/Python_2.7

Once it's been successfully rebuilt for F14, an update needs to be filed to get the rebuild into F14:
  https://admin.fedoraproject.org/updates/new/

Please add this bug to the update, to make it easy to track what's been done, and what's left to do.

Thanks!

Comment 1 Orcan Ogetbil 2010-08-02 20:08:26 UTC
For some reason, GTK_OBJECT_FLAGS get #undef'd, even if we 
#include <gtk/gtkobjects.h>

A workaround is to add
  #define GTK_OBJECT_FLAGS(obj)             (GTK_OBJECT (obj)->flags)

right before the lines where these two errors occur. Then the compilation succeeds. Sorry, I don't have time to look more at this. 

The maintainer could apply this workaround until the upstream gives a response.

Comment 2 Orcan Ogetbil 2010-08-05 04:29:15 UTC
ping: Karol? 

Did you work on this or submitted the issue upstream?
Or should we apply the workaround until you work on it?

Comment 3 Karol Trzcionka 2010-08-05 20:52:30 UTC
I've added patch with hack. These macros are (will be) deprecated and I've replaced it.
At now the problem is on i686 with gpgme. If it isn't fixed soon, I'll hack it.

Comment 4 Dave Malcolm 2010-08-12 00:19:03 UTC
*** Bug 623291 has been marked as a duplicate of this bug. ***

Comment 5 Fedora Update System 2010-08-24 07:21:10 UTC
ekg2-0.2-0.15.rc1.fc14 has been submitted as an update for Fedora 14.
http://admin.fedoraproject.org/updates/ekg2-0.2-0.15.rc1.fc14

Comment 6 Fedora Update System 2010-08-25 01:17:59 UTC
ekg2-0.2-0.15.rc1.fc14 has been pushed to the Fedora 14 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update ekg2'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/ekg2-0.2-0.15.rc1.fc14

Comment 7 Fedora Update System 2010-09-02 03:59:50 UTC
ekg2-0.2-0.15.rc1.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.