Bug 620113 - SELinux is preventing /usr/bin/kdm "read" access on /boot/grub/menu.lst.
SELinux is preventing /usr/bin/kdm "read" access on /boot/grub/menu.lst.
Status: CLOSED DUPLICATE of bug 540213
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
13
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Daniel Walsh
Fedora Extras Quality Assurance
setroubleshoot_trace_hash:7aa859cc38c...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-07-31 20:34 EDT by Scott Williams
Modified: 2010-08-02 12:01 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-08-02 12:01:29 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Scott Williams 2010-07-31 20:34:05 EDT
Summary:

SELinux is preventing /usr/bin/kdm "read" access on /boot/grub/menu.lst.

Detailed Description:

[SELinux is in permissive mode. This access was not denied.]

SELinux denied access requested by kdm. It is not expected that this access is
required by kdm and this access may signal an intrusion attempt. It is also
possible that the specific version or configuration of the application is
causing it to require additional access.

Allowing Access:

You can generate a local policy module to allow this access - see FAQ
(http://docs.fedoraproject.org/selinux-faq-fc5/#id2961385) Please file a bug
report.

Additional Information:

Source Context                system_u:system_r:xdm_t:s0-s0:c0.c1023
Target Context                unconfined_u:object_r:boot_t:s0
Target Objects                /boot/grub/menu.lst [ file ]
Source                        kdm
Source Path                   /usr/bin/kdm
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           kdm-4.4.5-1.fc13
Target RPM Packages           
Policy RPM                    selinux-policy-3.7.19-39.fc13
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Permissive
Plugin Name                   catchall
Host Name                     (removed)
Platform                      Linux (removed) 2.6.34.1-29.fc13.x86_64 #1 SMP
                              Fri Jul 23 00:22:01 UTC 2010 x86_64 x86_64
Alert Count                   4
First Seen                    Sat 31 Jul 2010 03:47:13 PM PDT
Last Seen                     Sat 31 Jul 2010 03:47:46 PM PDT
Local ID                      754a2564-ba63-4608-9157-383376bd81ff
Line Numbers                  

Raw Audit Messages            

node=(removed) type=AVC msg=audit(1280616466.686:350): avc:  denied  { read } for  pid=2022 comm="kdm" name="menu.lst" dev=sda1 ino=786700 scontext=system_u:system_r:xdm_t:s0-s0:c0.c1023 tcontext=unconfined_u:object_r:boot_t:s0 tclass=file

node=(removed) type=AVC msg=audit(1280616466.686:350): avc:  denied  { open } for  pid=2022 comm="kdm" name="menu.lst" dev=sda1 ino=786700 scontext=system_u:system_r:xdm_t:s0-s0:c0.c1023 tcontext=unconfined_u:object_r:boot_t:s0 tclass=file

node=(removed) type=SYSCALL msg=audit(1280616466.686:350): arch=c000003e syscall=2 success=yes exit=8 a0=41f2ea a1=0 a2=1b6 a3=0 items=0 ppid=1 pid=2022 auid=4294967295 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 tty=(none) ses=4294967295 comm="kdm" exe="/usr/bin/kdm" subj=system_u:system_r:xdm_t:s0-s0:c0.c1023 key=(null)



Hash String generated from  catchall,kdm,xdm_t,boot_t,file,read
audit2allow suggests:

#============= xdm_t ==============
allow xdm_t boot_t:file { read open };
Comment 1 Miroslav Grepl 2010-08-02 12:01:29 EDT

*** This bug has been marked as a duplicate of bug 540213 ***

Note You need to log in before you can comment on or make changes to this bug.