Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 620134 - [abrt] crash in openoffice.org-calc-1:3.1.1-19.34.fc12: IA__gdk_x11_drawable_get_xid: Process /usr/lib64/openoffice.org3/program/scalc.bin was killed by signal 11 (SIGSEGV)
[abrt] crash in openoffice.org-calc-1:3.1.1-19.34.fc12: IA__gdk_x11_drawable_...
Status: CLOSED DUPLICATE of bug 695582
Product: Fedora
Classification: Fedora
Component: openoffice.org (Show other bugs)
12
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Caolan McNamara
Fedora Extras Quality Assurance
abrt_hash:afed9911e76e591dc90a84a979a...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-08-01 03:21 EDT by Patrick Sefton
Modified: 2011-04-12 02:12 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-08-04 05:35:04 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (69.54 KB, text/plain)
2010-08-01 03:21 EDT, Patrick Sefton
no flags Details

  None (edit)
Description Patrick Sefton 2010-08-01 03:21:49 EDT
abrt 1.1.1 detected a crash.

architecture: x86_64
Attached file: backtrace
cmdline: /usr/lib64/openoffice.org3/program/scalc.bin -calc
component: openoffice.org
crash_function: IA__gdk_x11_drawable_get_xid
executable: /usr/lib64/openoffice.org3/program/scalc.bin
global_uuid: afed9911e76e591dc90a84a979aa88ab549a0f12
kernel: 2.6.32.16-141.fc12.x86_64
package: openoffice.org-calc-1:3.1.1-19.34.fc12
rating: 4
reason: Process /usr/lib64/openoffice.org3/program/scalc.bin was killed by signal 11 (SIGSEGV)
release: Fedora release 12 (Constantine)

How to reproduce
-----
1. Single document loaded in Writer
2. Right-clicked misspelled (red-underlined) word
3. Expected context-menu to appear
4. Context menu did not appear
5. Writer crashed
Comment 1 Patrick Sefton 2010-08-01 03:21:52 EDT
Created attachment 435833 [details]
File: backtrace
Comment 2 Caolan McNamara 2010-08-03 05:51:05 EDT
Doesn't happen here of course, so rare incident. It crashes in gtk2 at...

if( pWin )
{
    aWin = GDK_WINDOW_XWINDOW(pWin);

non NULL pWin. I have to assume that pWin is valid here.

Did it happen just once, or does it happen every time for you ?
Comment 3 Patrick Sefton 2010-08-03 06:35:44 EDT
(In reply to comment #2)
> Doesn't happen here of course, so rare incident. It crashes in gtk2 at...
> 
> if( pWin )
> {
>     aWin = GDK_WINDOW_XWINDOW(pWin);
> 
> non NULL pWin. I have to assume that pWin is valid here.
> 
> Did it happen just once, or does it happen every time for you ?    


No, doesn't happen every time, but does happen intermittently.  Can't duplicate it at present, but the common factor when this happens is that it occurs when I have previously opened a document within Firefox (ie so that that doc appears as editable using writer within the Firefox window or tab).  Then the crash happens when I go back to doing something in the Writer main window.

Sorry -- not super helpful I know.  I'll see if I can reliably duplicate the crash.
Comment 4 Caolan McNamara 2010-08-04 05:35:04 EDT
Looks like a gtk bug to me, but seeing as you mention firefox, I see that firefox has a long history of "gdk_x11_drawable_get_xid" bugs in F-12. I strongly suspect that its the same issue

*** This bug has been marked as a duplicate of bug 547790 ***
Comment 5 David Tardon 2011-04-12 02:12:34 EDT

*** This bug has been marked as a duplicate of bug 695582 ***

Note You need to log in before you can comment on or make changes to this bug.