Bug 62014 - 2.4.9-31smp does not boot
2.4.9-31smp does not boot
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
7.2
athlon Linux
medium Severity medium
: ---
: ---
Assigned To: Arjan van de Ven
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-03-26 14:19 EST by adler
Modified: 2007-04-18 12:41 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-03-26 14:25:55 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
dmesg output from working smp athalon system (15.02 KB, text/plain)
2002-03-26 14:20 EST, adler
no flags Details

  None (edit)
Description adler 2002-03-26 14:19:26 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.2.1) Gecko/20010901

Description of problem:
I can't get my dual athalon system booting with 2.4.9-31smp

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.buy an dual athalon system.
2.load 2.4.9-31smp
3.Try and boot it in SMP mode
	

Actual Results:  hang.

Expected Results:  full running system

Additional info:

Here's the deal. I have purchased 2 dual AMD systems. Motherboard is an ASUS
A7M266-D and the CPU's are AMD Athalon MP 1800+. The two have slightly different
periferals, but the basic motherboard/CPU/Memory is the same. The first system
was purchased 3 months ago, and basically worked great "right out of the box".
The second system works great in UP mode, but fails to boot in SMP mode. One
thing to note, the first system would not boot in SMP mode unless the
smp-athalon kernel was loaded. Both systems have the athalon smp kernel loaded.

The last boot messages the problem system prints to the screen while trying to
boot into smp mode is the following.

CPU1: AMD Athalon(TM) XP 1800+ stepping 02
Total of 2 processors activated (6121.06 Bogomips)
Enableing IO-APIC IRQs
... changing IO-APIC physical APIC ID to 2... ok.
.. TIMER vector=0x31 pin1=2 pin2=0
testing the IO APIC.............
.........  done.
Using local APIC timer interupts.
Calibrating APIC timer...
.... CPU clock speed is 1533.2891 MHz.
..... Host bus clock speed is 266.6590 Mhz.
cpu:0, cloks 2666590, slice: 888868
CPU<T0: 2666576, T1: 1777712, D:1, S: 888862, C:2666590>

and that's it.

What I have done is load as a seperate text file the dmesg output from the
working system. You can see that there is a differnece between the two at the
hang point. It looks like the working system is able to init the IO-APIC IRQ's
since you get that message in the working system just about at the point when
the failing system hangs.

I've checked the jumper and bios settings on both system and they are identical.
I hope you guys have an idea of what is going on here.
Comment 1 adler 2002-03-26 14:20:59 EST
Created attachment 50544 [details]
dmesg output from working smp athalon system
Comment 2 adler 2002-03-26 14:22:20 EST
one other note, I have not tried earlier versions of the 2.4.9 kernel. I don't
expect different results but if you guys want me to try that, I can.
Comment 3 Alan Cox 2002-03-26 14:58:26 EST
Known problem. Ask ASUS for BIOS fixes

You can sort of work around the one problem by setting the BIOS to MP1.1, but
you may well find the board is still not correctly configured with some card
combinations, and is not setting PCI 2.2 compliance. 

The RH beta fixes that one up, but we can't fix the MP 1.4 table problem.

I've got open items with AMD about this board and its problems.
Comment 4 adler 2002-03-26 16:07:47 EST
I want to thank Alan Cox for helping me on this problem. Just for the record,
the  ASUS A7M266-D motherboard's bios has an option to enable or disable MP 1.4.
The section is found under the BIOS Boot menu. When I set the MP 1.4 option to
disable, the system booted up in smp mode. I don't know what the difference is
between MP 1.4 or 1.1, as Alan talks about, if I gain in performance with 1.4 or
what, but at least I have 2 CPU's running. Thank you Red Hat and Alan for
helping me with this.

Note You need to log in before you can comment on or make changes to this bug.