Bug 620189 - No sound line-in/Mic-in intel-hda ALC892 + Workaround
Summary: No sound line-in/Mic-in intel-hda ALC892 + Workaround
Status: CLOSED NEXTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel   
(Show other bugs)
Version: 15
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Jaroslav Kysela
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-08-01 13:22 UTC by Electron
Modified: 2012-06-15 01:29 UTC (History)
10 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-15 01:29:26 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Electron 2010-08-01 13:22:22 UTC
Description of problem:
This bug concerns PulseAudio or Alsa or Kernel. I post here in the doubt.

No sound Capture Line-in or Mic-in.
Level meter freeze after 0 to 10 sec.

Version-Release number of selected component (if applicable):

pulseaudio-0.9.21-6.fc13.i686
KERNEL 2.6.33.6-147.2.4.fc13.i686.PAE

---
Need patch kernel ? 
like ( https://launchpad.net/bugs/587546 )
like ( http://www.kernel.org/diff/diffview.cgi?file=%2Fpub%2Flinux%2Fkernel%2Fv2.6%2Fpatch-2.6.34.1.bz2;z=199 )
---

MotherBoard ASUS M4A89GTD PRO

lspci -nv|grep -A1 0403

00:14.2 0403: 1002:4383 (rev 40)
	Subsystem: 1043:8410
--
01:05.1 0403: 1002:970f
	Subsystem: 1002:970f

lspci | grep -i audio
00:14.2 Audio device: ATI Technologies Inc SBx00 Azalia (Intel HDA) (rev 40)
01:05.1 Audio device: ATI Technologies Inc RS880 Audio Device [Radeon HD 4200]
03:05.1 Multimedia controller: Brooktree Corporation Bt878 Audio Capture (rev 11)

aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: SB [HDA ATI SB], device 0: ALC892 Analog [ALC892 Analog]
  Subdevices: 0/1
  Subdevice #0: subdevice #0
card 0: SB [HDA ATI SB], device 1: ALC892 Digital [ALC892 Digital]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 2: HDMI [HDA ATI HDMI], device 3: ATI HDMI [ATI HDMI]
  Subdevices: 1/1
  Subdevice #0: subdevice #0


How reproducible:


Steps to Reproduce:
1.Install Fedora 13
2.No Sound by line-in or Mic-in 
3.Create file /etc/modprobe.d/alsa-base.conf (Contents of the file " options snd-hda-intel position_fix=1 " (without quote)
4.Shutdown/Power on computer
5.Problem disappears :-)
  
Actual results:
That works. But I lost some hair!

Expected results:

All works out box ;-)

Additional info:

Comment 1 Zoltan Hoppar 2010-08-21 01:06:46 UTC
This is the solution too for HP Probook 4515 - with RS 880 Azalia (STALC96xx chip) - and hopefully for many ALC chip. So I confirm that works!

Comment 2 Bug Zapper 2011-06-01 12:21:11 UTC
This message is a reminder that Fedora 13 is nearing its end of life.
Approximately 30 (thirty) days from now Fedora will stop maintaining
and issuing updates for Fedora 13.  It is Fedora's policy to close all
bug reports from releases that are no longer maintained.  At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '13'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 13's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 13 is end of life.  If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora please change the 'version' of this 
bug to the applicable version.  If you are unable to change the version, 
please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events.  Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
http://fedoraproject.org/wiki/BugZappers/HouseKeeping

Comment 3 Electron 2011-06-02 10:01:00 UTC
For me, the workaround is no longer necessary with Fedora 15 and the same hardware.
I have not tried the F14 with the latest update.
I think we can close the bug, right?

Comment 4 Electron 2011-06-04 11:15:35 UTC
Sorry, I still have to apply the workaround after cold reboot :-(

Comment 5 Josh Boyer 2012-06-04 15:20:17 UTC
Are you still seeing this with the 2.6.43/3.3 kernel update in F15/F16?

Comment 6 Electron 2012-06-14 21:14:29 UTC
Hello, 
I tried Fedora 17 with kernel 3.3.7-1.fc17.x86_64 and 3.4.0-1.fc17.x86_64. The workaround seems unnecessary now (same hardware of course).
No objections to closing the bug for me :-)

Comment 7 Josh Boyer 2012-06-15 01:29:26 UTC
Thanks.


Note You need to log in before you can comment on or make changes to this bug.