Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 620214 - rpm and yum broken after upgrade due to undefined symbol in librpm
rpm and yum broken after upgrade due to undefined symbol in librpm
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: rpm (Show other bugs)
13
All Linux
low Severity high
: ---
: ---
Assigned To: Panu Matilainen
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-08-01 11:13 EDT by David Howells
Modified: 2010-08-02 05:44 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-08-02 05:44:52 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David Howells 2010-08-01 11:13:33 EDT
Description of problem:

I had a Fedora 13 installation on my desktop, which I just ran a yum upgrade on.  Now rpm and yum are both pretty broken due to an undefined symbol 'pgpValString' in librpm:

[root@localhost ~]# yum
There was a problem importing one of the Python modules
required to run yum. The error leading to this problem was:

   /usr/lib64/librpm.so.1: undefined symbol: pgpValString

Please install a package which provides this module, or
verify that the module is installed correctly.

It's possible that the above module doesn't match the
current version of Python, which is:
2.6.4 (r264:75706, Jun  4 2010, 18:20:31) 
[GCC 4.4.4 20100503 (Red Hat 4.4.4-2)]

If you cannot solve this problem yourself, please go to 
the yum faq at:
  http://yum.baseurl.org/wiki/Faq

[root@localhost ~]# rpm -qi rpm
rpm: symbol lookup error: /usr/lib64/librpm.so.1: undefined symbol: pgpValString

Version-Release number of selected component (if applicable):

[root@localhost ~]# rpm -q rpm rpm-libs yum
Freeing read locks for locker 0x31fd: 3659/140596657260448
Freeing read locks for locker 0x31fe: 3659/140596657260448
Freeing read locks for locker 0x31ff: 3659/140596657260448
rpm-4.8.1-2.fc13.x86_64
rpm-libs-4.8.1-2.fc13.x86_64
rpm-libs-4.8.1-2.fc13.i686
yum-3.2.27-4.fc13.noarch

How reproducible:

I'm not sure how to reproduce this.  My guess is there's something not right in the Python libraries, but I'm not sure what.  I upgraded my system from F-12 shortly after F-13 was released and haven't upgraded it since, until today.
Comment 1 David Howells 2010-08-02 05:44:52 EDT
Ah...  It seems a copy of librpmio got installed to /usr/local/lib back in May when I was fixing a bug debugedit.  I don't recall installing it myself, but I may have done.

Note You need to log in before you can comment on or make changes to this bug.