Bug 620257 - BackupPC-debuginfo-3.1.0-15 contains no sources
BackupPC-debuginfo-3.1.0-15 contains no sources
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: BackupPC (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Johan Cwiklinski
Fedora Extras Quality Assurance
: Regression
Depends On:
Blocks: DebugInfo
  Show dependency treegraph
 
Reported: 2010-08-01 16:13 EDT by Ville Skyttä
Modified: 2010-09-08 00:39 EDT (History)
1 user (show)

See Also:
Fixed In Version: BackupPC-3.1.0-16.fc14
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-09-08 00:39:14 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ville Skyttä 2010-08-01 16:13:55 EDT
BackupPC-debuginfo-3.1.0-15 contains no sources.  Looks like 3.1.0-14.1 did not have this problem.  See blocker bug for pointers to possible fixes; I suppose the suid bit at end of %install might cause this and the fix could be to not add the suid bit there but later in the %files section.
Comment 1 Johan Cwiklinski 2010-08-02 15:58:08 EDT
The problem does not exists before -15.fc14 release because of bug #611009 ; I had to add a C wrapper to avoid this issue.

I've tried to remove the suid bit at %install ; that does not solve the issue.

I wonder if disabling debuginfo for that is not the solution.
If that is not, I'll need some help and/or advices, as I really have no idea what's wrong and how to fix that.
Comment 2 Johan Cwiklinski 2010-08-02 16:32:46 EDT
Well, nevermind... Thanks to Pikachu_2014 on IRC, I've understand what the problem is and how to solve it.

The .c file is a separate source (Source4), and therefore is not included in the BUILD directory ; where the find-debuginfo.sh script is looking for it.

I've fixed the issue copying the Source4 to the BUILD directory in the %prep section, the issue seems to be resolved this way.

I'll commit the change and rebuild the package soonly.
Comment 3 Fedora Update System 2010-08-02 17:13:27 EDT
BackupPC-3.1.0-16.fc14 has been submitted as an update for Fedora 14.
http://admin.fedoraproject.org/updates/BackupPC-3.1.0-16.fc14
Comment 4 Fedora Update System 2010-08-02 22:14:14 EDT
BackupPC-3.1.0-16.fc14 has been pushed to the Fedora 14 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update BackupPC'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/BackupPC-3.1.0-16.fc14
Comment 5 Fedora Update System 2010-09-08 00:39:10 EDT
BackupPC-3.1.0-16.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.