Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 620265 - python-pydns needs to be rebuilt against python 2.7 in F14 and devel
python-pydns needs to be rebuilt against python 2.7 in F14 and devel
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: python-pydns (Show other bugs)
14
All Linux
low Severity medium
: ---
: ---
Assigned To: jafo-redhat
Fedora Extras Quality Assurance
:
Depends On:
Blocks: Python27Rebuild
  Show dependency treegraph
 
Reported: 2010-08-01 17:33 EDT by Dave Malcolm
Modified: 2010-08-02 22:18 EDT (History)
1 user (show)

See Also:
Fixed In Version: python-pydns-2.3.3-6.fc14
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-08-02 22:18:28 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dave Malcolm 2010-08-01 17:33:19 EDT
The package needs to be rebuilt against python 2.7 in both F14 and devel.

Automated rebuild fails; python 2.7 seems to be more picky about encoding issues than previous versions:
http://koji.fedoraproject.org/koji/getfile?taskID=2369971&name=build.log
I'll take a look at this.



Information on the new "dist-git" system can be seen here:
  http://fedoraproject.org/wiki/Using_Fedora_GIT

Information on common difficulties with Python 2.7 rebuilds can be seen here:
  https://fedoraproject.org/wiki/Features/Python_2.7

Once it's been successfully rebuilt for F14, an update needs to be filed to get the rebuild into F14:
  https://admin.fedoraproject.org/updates/new/

Please add this bug to the update, to make it easy to track what's been done, and what's left to do.

Thanks!
Comment 1 Dave Malcolm 2010-08-01 17:37:10 EDT
[david@brick DNS]$ file *.py
Base.py:     ASCII English text
Class.py:    ASCII English text
__init__.py: ASCII English text
lazy.py:     ASCII English text
Lib.py:      ISO-8859 English text
Opcode.py:   ASCII English text
Status.py:   ASCII English text
Type.py:     ISO-8859 English text
win32dns.py: ASCII English text

Using hexdump, it looks like Lib.py and Type.py contain one-byte encodings of "Michael Ströder"'s name.

However, __init__.py, Lib.py and Type.py all come (upstream) with:
  # -*- encoding: utf-8 -*-
lines (which appear to be incorrect for the two above; the "ö" should be two-bytes in UTF-8, I believe).

The specfile adds a downstream:
  # -*- coding: latin-1 -*-
to the top of every file, so the three files above end up with two "encoding" lines; I believe that that's what python 2.7 is complaining about
Comment 2 Dave Malcolm 2010-08-01 18:06:37 EDT
Fix committed and pushed to f14 and master.

Rebuilding for f14 as:
  http://koji.fedoraproject.org/koji/taskinfo?taskID=2372363

and for f15 as:
  http://koji.fedoraproject.org/koji/taskinfo?taskID=2372365
Comment 3 Fedora Update System 2010-08-01 18:12:27 EDT
python-pydns-2.3.3-6.fc14 has been submitted as an update for Fedora 14.
http://admin.fedoraproject.org/updates/python-pydns-2.3.3-6.fc14
Comment 4 Fedora Update System 2010-08-02 22:18:24 EDT
python-pydns-2.3.3-6.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.