Bug 620281 - python-daemon needs to be rebuilt against python 2.7 in F14 and devel
python-daemon needs to be rebuilt against python 2.7 in F14 and devel
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: python-daemon (Show other bugs)
14
All Linux
low Severity medium
: ---
: ---
Assigned To: Silas Sewell
Fedora Extras Quality Assurance
:
Depends On:
Blocks: Python27Rebuild
  Show dependency treegraph
 
Reported: 2010-08-01 19:52 EDT by Dave Malcolm
Modified: 2010-08-05 10:26 EDT (History)
3 users (show)

See Also:
Fixed In Version: python-lockfile-0.8-1.fc14
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-08-05 10:26:30 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dave Malcolm 2010-08-01 19:52:22 EDT
The package needs to be rebuilt against python 2.7 in both F14 and devel.

I tried to rebuilt this automatically, but there was an error.

Looking at the logs
http://koji.fedoraproject.org/koji/getfile?taskID=2369987&name=build.log

the issue is:
+ nosetests
E
======================================================================
ERROR: Failure: TypeError (Error when calling the metaclass bases
    function() argument 1 must be code, not str)
----------------------------------------------------------------------
Traceback (most recent call last):
  File "/usr/lib/python2.7/site-packages/nose/loader.py", line 382, in loadTestsFromName
    addr.filename, addr.module)
  File "/usr/lib/python2.7/site-packages/nose/importer.py", line 39, in importFromPath
    return self.importFromDir(dir_path, fqname)
  File "/usr/lib/python2.7/site-packages/nose/importer.py", line 86, in importFromDir
    mod = load_module(part_fqname, fh, filename, desc)
  File "/builddir/build/BUILD/python-daemon-1.5.2/test/__init__.py", line 19, in <module>
    suite = scaffold.make_suite()
  File "/builddir/build/BUILD/python-daemon-1.5.2/test/scaffold.py", line 58, in make_suite
    suite = loader.loadTestsFromNames(test_module_names)
  File "/usr/lib/python2.7/unittest/loader.py", line 128, in loadTestsFromNames
    suites = [self.loadTestsFromName(name, module) for name in names]
  File "/usr/lib/python2.7/unittest/loader.py", line 91, in loadTestsFromName
    module = __import__('.'.join(parts_copy))
  File "/builddir/build/BUILD/python-daemon-1.5.2/test/test_runner.py", line 24, in <module>
    from test_pidlockfile import (
  File "/builddir/build/BUILD/python-daemon-1.5.2/test/test_pidlockfile.py", line 26, in <module>
    from daemon import pidlockfile
  File "/builddir/build/BUILD/python-daemon-1.5.2/daemon/pidlockfile.py", line 33, in <module>
    class PIDLockFile(LinkFileLock, object):
TypeError: Error when calling the metaclass bases
    function() argument 1 must be code, not str
----------------------------------------------------------------------


Information on the new "dist-git" system can be seen here:
  http://fedoraproject.org/wiki/Using_Fedora_GIT

Information on common difficulties with Python 2.7 rebuilds can be seen here:
  https://fedoraproject.org/wiki/Features/Python_2.7

Once it's been successfully rebuilt for F14, an update needs to be filed to get the rebuild into F14:
  https://admin.fedoraproject.org/updates/new/

Please add this bug to the update, to make it easy to track what's been done, and what's left to do.

Thanks!
Comment 1 Thomas Spura 2010-08-02 07:07:59 EDT
There is a new upstream release, that has the same problem...

I just mailed the author about this, hopefully he knows, what's going on.
Comment 2 Thomas Spura 2010-08-02 08:06:40 EDT
This happened, because python-lockfile changed the API...

Reverting the python-lockfile update will solve this issue.
Comment 3 Silas Sewell 2010-08-02 08:59:25 EDT
OK, it doesn't look like I'm going to get an answer about this (http://code.google.com/p/pylockfile/issues/detail?id=4) from upstream.

Thomas: Should I just epoch this and revert to "lockfile 0.8" (and just completely ignore 0.9)?
Comment 4 Thomas Spura 2010-08-02 16:00:28 EDT
(In reply to comment #3)
> OK, it doesn't look like I'm going to get an answer about this
> (http://code.google.com/p/pylockfile/issues/detail?id=4) from upstream.
> 
> Thomas: Should I just epoch this and revert to "lockfile 0.8" (and just
> completely ignore 0.9)?    

Yes, please :)

I guess, there is no other way to avoid epoch...
Comment 5 Fedora Update System 2010-08-03 07:47:58 EDT
python-lockfile-0.8-1.fc14 has been submitted as an update for Fedora 14.
http://admin.fedoraproject.org/updates/python-lockfile-0.8-1.fc14
Comment 6 Thomas Spura 2010-08-03 08:01:26 EDT
Thanks Silas,

python-damon builds now:
http://koji.fedoraproject.org/koji/taskinfo?taskID=2376497

Could you please push your update directly to stable?
It works seemingly, because the testsuite of python-damon now also passes.
Comment 7 Fedora Update System 2010-08-05 10:26:25 EDT
python-lockfile-0.8-1.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.