Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 62031 - New IDE controller not recognized
New IDE controller not recognized
Status: CLOSED ERRATA
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
7.3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Arjan van de Ven
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-03-26 16:21 EST by Philip Pokorny
Modified: 2007-04-18 12:41 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-06-07 22:31:52 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Portion of /tmp/syslog from installer (982 bytes, text/plain)
2002-03-26 17:25 EST, Philip Pokorny
no flags Details
Patch to make piix.c service 8086:248b (2.64 KB, patch)
2002-03-26 22:02 EST, Philip Pokorny
no flags Details | Diff
dmesg from patched kernel (18.04 KB, text/plain)
2002-03-26 22:03 EST, Philip Pokorny
no flags Details
Disable PCI EINVAL on unallocated regions (834 bytes, patch)
2002-04-15 21:17 EDT, Philip Pokorny
no flags Details | Diff

  None (edit)
Description Philip Pokorny 2002-03-26 16:21:41 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i586; en-US; rv:0.9.2.1) Gecko/20010901

Description of problem:
The PIIX derived IDE controller in the Intel i7500 chipset used in dual P4 Xeon
systems is not recognized by the IDE driver.

UDMA5 and DMA are not enabled as a result and performance suffers dramatically.

The new PCI ID's are  VID: 8086  DID: 248b

Will attach syslog from installer BOOT kernel when install completes.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Boot skipjack on i7500 based motherboard


Actual Results:  As reported by /proc/ide/hda/settings:

current_speed = 0
using_dma = 0

Expected Results:  current_speed = 69
using_dma = 1

Additional info:
Comment 1 Philip Pokorny 2002-03-26 17:25:26 EST
Created attachment 50684 [details]
Portion of /tmp/syslog from installer
Comment 2 Philip Pokorny 2002-03-26 17:27:52 EST
I would have included the entire syslog, but as the install completed, I got a
spew of EEPRO100_WAIT_FOR_CMD timeouts and the machine locked up.  I was doing
an NFS install.
Comment 3 Philip Pokorny 2002-03-26 22:00:38 EST
Assuming that the new DID:248b is the same as DID:248a, I have created the
attached patch.  This causes the PCI device to be identitfied as a PIIX4, but
still no joy due to a "resource collision".

Not sure how to track down the resource collision.  DMIDECODE reports "checksum
error" and fails to print much of any use to me.

# dmidecode
PNP BIOS present.
RSD PTR found at 0xF5D00
checksum failed.
OEM ACPIAM
Any ideas on how to track down the resource collision?
Comment 4 Philip Pokorny 2002-03-26 22:02:21 EST
Created attachment 50765 [details]
Patch to make piix.c service 8086:248b
Comment 5 Philip Pokorny 2002-03-26 22:03:45 EST
Created attachment 50766 [details]
dmesg from patched kernel
Comment 6 Arjan van de Ven 2002-03-27 06:56:48 EST
Resource collisions are bios bugs....
Comment 7 Arjan van de Ven 2002-03-28 09:26:19 EST
We need to get confirmation from one of the ide people that this chip in deed is
a piix4; this might or might not make the release..... at least it works even
without the ident.
Comment 8 Arjan van de Ven 2002-04-11 08:52:31 EDT
please test 2.4.18-0.19 or 2.4.18-0.20 in rawhide
It should have this working
(some of these messages are still bios bugs it seems, but unavoidable if the hw
needs to pass MSFT certification)
Comment 9 Philip Pokorny 2002-04-12 12:46:29 EDT
I find 2.4.18-0.21 in Rawhide today.  Will download it then install
skipjack/beta4 and that kernel and see what happens.

Is there a new dmidecode as well?  What are the MSFT compatibility issues?
Comment 10 Arjan van de Ven 2002-04-12 12:48:17 EDT
No new dmidecode; that looks like a bios bug

Microsoft seems to require the PCI BAR's to be in a certain state (off mostly :)
and ACPI is the only thing that can enable them then.
Comment 11 Arjan van de Ven 2002-04-14 09:35:04 EDT
any news on the kernel ?
Comment 12 Philip Pokorny 2002-04-15 21:16:12 EDT
Sorry for the delay...

The 0.21 kernel did not solve the problem.  However, the following sledgehammer
of a patch did...

Basically, I told the pci-i386.c functions to ignore the fact that a region on a
PCI device had not been allocated an address.

Reading the Intel specs for the 82801CA chip suggest that it has a "legacy" and
"native" mode now where the first 4 regions (0 to 3) can be used to decode the
command and control registers for the primary and secondary interfaces
independantly.  Perhaps this makes a device driver easier to write?

In any case, this would seem to clearly suggest that Tyan's got a BIOS bug. 
They either need to allocate the regions, or disable them.  Either way, the
Linux device driver doesn't (currently) use them and won't care.
Comment 13 Philip Pokorny 2002-04-15 21:17:55 EDT
Created attachment 53904 [details]
Disable PCI EINVAL on unallocated regions
Comment 14 Alan Cox 2002-07-28 19:32:12 EDT
Your change will cause random machine hangs
Comment 15 Alan Cox 2003-06-07 22:31:52 EDT
Correct fix in current errata

Note You need to log in before you can comment on or make changes to this bug.