Bug 620350 - (CVE-2010-2792) CVE-2010-2792 spice-xpi/qspice-client unix socket race
CVE-2010-2792 spice-xpi/qspice-client unix socket race
Status: NEW
Product: Security Response
Classification: Other
Component: vulnerability (Show other bugs)
unspecified
All Linux
medium Severity medium
: ---
: ---
Assigned To: Red Hat Product Security
impact=moderate,public=20100825,repor...
: Security
Depends On: 581969 619069 620444 620447 620471 620473
Blocks:
  Show dependency treegraph
 
Reported: 2010-08-02 05:41 EDT by Petr Matousek
Modified: 2016-12-04 15:36 EST (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed:
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Petr Matousek 2010-08-02 05:41:38 EDT
There is a race in spice-xpi when a local attacker is able to create a unix socket with the expected name that is used for parameter passing (password, cert file) between spice-xpi and spice client.
Comment 2 errata-xmlrpc 2010-08-25 08:08:53 EDT
This issue has been addressed in following products:

  Red Hat Enterprise Linux 5

Via RHSA-2010:0632 https://rhn.redhat.com/errata/RHSA-2010-0632.html
Comment 3 errata-xmlrpc 2010-08-25 08:12:01 EDT
This issue has been addressed in following products:

  Red Hat Enterprise Linux 5

Via RHSA-2010:0651 https://rhn.redhat.com/errata/RHSA-2010-0651.html

Note You need to log in before you can comment on or make changes to this bug.