Bug 62036 - Bad arrangement of files in /usr/X11R6/lib/X11/fonts/latin2 directory
Bad arrangement of files in /usr/X11R6/lib/X11/fonts/latin2 directory
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: XFree86 (Show other bugs)
7.2
All Linux
medium Severity medium
: ---
: ---
Assigned To: Mike A. Harris
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-03-26 16:33 EST by J. J. Ramsey
Modified: 2007-04-18 12:41 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-03-26 16:33:59 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description J. J. Ramsey 2002-03-26 16:33:54 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.2.1) Gecko/20010901

Description of problem:
The placement of the .pfm and .afm files in the /usr/X11R6/lib/X11/fonts/latin2
directory causes xfontsel to hang when trying to view ult1mo fonts, and
StarOffice 5.2's installation program's fonts to look wrong; the "fixed" font
appears instead of the normal Arial/Helvetica. .pfm and .afm files are in
separate directories, while the .pfb files are right in
/usr/X11R6/lib/X11/fonts/latin2 proper. BTW, the .pfm, .afm, and .pfb files are
compressed, which may or may not have been part of the problem.

To fix the problem, I uncompressed the .pfm, .afm., and .pfb files and moved the
.pfm and .afm files into the main /usr/X11R6/lib/X11/fonts/latin2 directory.
This allowed xfontsel to not hang when viewing the ult1mo fonts, and the
StarOffice install program to look and work right.


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
Try to view fonts from the ult1mo foundry with xfontsel.
	

Additional info:
Comment 1 Mike A. Harris 2002-03-28 09:52:47 EST
ulT1mo fonts have been removed from our XFree86 packages and are now part of
the fonts-ISO8859-2 package.  I have just installed a fresh copy of XFree86
4.2.0 from rawhide, along with the newest fonts-ISO8859-2 package.

I just tested and confirmed working, a whole pile of permutations of
ulT1mo foundry in xfontsel, and am not able to reproduce this problem.
The new packaging seems to differ slightly which could account for
it working properly now.

Closing as fixed in RAWHIDE.

Note You need to log in before you can comment on or make changes to this bug.