Bug 620407 - prefetch exceeds receiver capacity
Summary: prefetch exceeds receiver capacity
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: python-qpid   
(Show other bugs)
Version: 6.0
Hardware: All Linux
low
high
Target Milestone: rc
: ---
Assignee: Rafael H. Schloming
QA Contact: MRG Quality Engineering
URL:
Whiteboard:
Keywords:
Depends On: 620402
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-08-02 13:18 UTC by Rafael H. Schloming
Modified: 2014-12-01 23:15 UTC (History)
6 users (show)

Fixed In Version: python-qpid-0.7.946106-12
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 620402
Environment:
Last Closed: 2010-11-10 21:23:32 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Rafael H. Schloming 2010-08-02 13:18:48 UTC
+++ This bug was initially created as a clone of Bug #620402 +++

Description of problem:

The credit logic allows the number of prefetched messages to exceed the receiver capacity. This was first noticed due to an extremely intermittent failure in ReceiverTest.testCapacity. New capacity tests have been added that show this more frequently.

How reproducible:

~1% with old testCapacity, and ~80-90% with new variants of testCapacity

Steps to Reproduce:

Run qpid-python-test *.testCapacity*
  
Actual results:

Test frequently fails.

Expected results:

Test should always pass.

Comment 1 Rafael H. Schloming 2010-08-02 13:23:37 UTC
This bug effectively disables flow control for the python client. This would be an extremely severe issue for anyone using it. The fix is already done.

Comment 2 Gordon Sim 2010-08-02 15:42:36 UTC
To restate the impact for added clarity, anyone using the python client would not be able to effectively limit incoming messages.

Comment 4 Rafael H. Schloming 2010-08-10 11:47:00 UTC
Yes, the fix is already in the mrg release for RHEL 4 and 5. It would just be a matter of rebuilding the rpm on RHEL 6.

Comment 6 releng-rhel@redhat.com 2010-11-10 21:23:32 UTC
Red Hat Enterprise Linux 6.0 is now available and should resolve
the problem described in this bug report. This report is therefore being closed
with a resolution of CURRENTRELEASE. You may reopen this bug report if the
solution does not work for you.


Note You need to log in before you can comment on or make changes to this bug.