Bug 620434 - [abrt] setroubleshoot-server-2.2.91-2.fc14: base.py:957:request:AttributeError: HTTPSConnection instance has no attribute 'getreply'
Summary: [abrt] setroubleshoot-server-2.2.91-2.fc14: base.py:957:request:AttributeErro...
Status: CLOSED DUPLICATE of bug 621298
Alias: None
Product: Fedora
Classification: Fedora
Component: python-bugzilla   
(Show other bugs)
Version: 14
Hardware: All
OS: Linux
low
high
Target Milestone: ---
Assignee: Will Woods
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:3572f49e
Keywords:
Depends On:
Blocks: Python27
TreeView+ depends on / blocked
 
Reported: 2010-08-02 14:07 UTC by Frank Murphy
Modified: 2010-08-04 18:04 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-08-04 18:04:53 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (2.73 KB, text/plain)
2010-08-02 14:07 UTC, Frank Murphy
no flags Details

Description Frank Murphy 2010-08-02 14:07:17 UTC
abrt version: 1.1.10
architecture: i686
Attached file: backtrace
cmdline: /usr/bin/python -Es /usr/bin/sealert -s
comment: Trying to send sealert to bugzilla
component: setroubleshoot
executable: /usr/bin/sealert
kernel: 2.6.35-0.57.rc6.git1.fc14.i686
package: setroubleshoot-server-2.2.91-2.fc14
reason: base.py:957:request:AttributeError: HTTPSConnection instance has no attribute 'getreply'
release: Fedora release 14 (Branched)
time: 1280757913
uid: 500

How to reproduce
-----
1. Tried to send alert to bugzilla
2. enter user\password 
3. tick keep in keyring

Comment 1 Frank Murphy 2010-08-02 14:07:19 UTC
Created attachment 436029 [details]
File: backtrace

Comment 2 Adam Williamson 2010-08-03 18:37:26 UTC
Package: setroubleshoot-server-2.2.91-2.fc14
Architecture: x86_64
OS Release: Fedora release 14 (Branched)


How to reproduce
-----
1. Tried to submit a report of an SELinux AVC
2.
3.

Comment 3 Daniel Walsh 2010-08-03 18:53:05 UTC
This looks like a 2.7 issue.

Might be a problem in the bugzilla package.

Comment 4 Dave Malcolm 2010-08-03 19:10:26 UTC
Looks similar to bug 620879

Comment 5 Dave Malcolm 2010-08-04 17:29:44 UTC
Trivial reproducer:

Run
  bugzilla info -p
to query a list of products.  Fails immediately with a similar traceback to comment #1.

Reassigning to python-bugzilla.

I'm investigating this.

Comment 6 Dave Malcolm 2010-08-04 18:04:53 UTC

*** This bug has been marked as a duplicate of bug 621298 ***


Note You need to log in before you can comment on or make changes to this bug.