Bug 620523 - anaconda not correctly detecting HP Smart Array P410i RAID controller
anaconda not correctly detecting HP Smart Array P410i RAID controller
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: kernel (Show other bugs)
6.0
x86_64 Linux
low Severity medium
: rc
: ---
Assigned To: Tony Camuso
Red Hat Kernel QE team
: RHELNAK
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-08-02 14:52 EDT by pob
Modified: 2010-09-14 10:07 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-09-14 10:07:01 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description pob 2010-08-02 14:52:49 EDT
Description of problem:
anaconda (and I suppose RHEL6 in general) is not correctly detecting the HP Smart Array P410i RAID controller. the P410i controller is pretty much standard on all DL/BL 300 G6 series hosts.

Version-Release number of selected component (if applicable):
RHEL6.0-20100715.2-Server-x86_64

How reproducible:
if you have the hardware, very.

Steps to Reproduce:
1. Grab a G6 DL360 or BL460 (the two models of hosts I tried this on with P410i controllers)
2. try to install RHEL via DVD or kickstart
  
Actual results:
/dev/sda shows up as the logical disk

Expected results:
/dev/cciss/c0d0 shows up as the logical disk

Additional info:
I would attach the logs, but they don't appear to be all that helpful. Anaconda doesn't pick up the controller and the cciss driver never gets loaded. I have also opened a ticket with HP for this.
Comment 1 Chris Lumens 2010-08-02 15:00:14 EDT
If the driver's not getting loaded, anaconda will never be able to detect the disks attached to it.
Comment 3 RHEL Product and Program Management 2010-08-02 15:29:39 EDT
This issue has been proposed when we are only considering blocker
issues in the current Red Hat Enterprise Linux release.

** If you would still like this issue considered for the current
release, ask your support representative to file as a blocker on
your behalf. Otherwise ask that it be considered for the next
Red Hat Enterprise Linux release. **
Comment 4 pob 2010-08-02 16:45:28 EDT
I neglected to mention that loading the driver manually via kickstart's 'driver' option does not help either.
Comment 5 pob 2010-08-06 11:27:51 EDT
This really isn't a bug afterall - it looks like HP submitted the hpsa driver to the 2.6.34 kernel which white lists some controllers to use the hpsa kernel module.

from: http://git.kernel.org/?p=linux/kernel/git/stable/linux-2.6.34.y.git;a=blob_plain;f=drivers/scsi/hpsa.c;hb=HEAD

static struct board_type products[] = {
	{0x3241103C, "Smart Array P212", &SA5_access},
	{0x3243103C, "Smart Array P410", &SA5_access},
	{0x3245103C, "Smart Array P410i", &SA5_access},
	{0x3247103C, "Smart Array P411", &SA5_access},
	{0x3249103C, "Smart Array P812", &SA5_access},
	{0x324a103C, "Smart Array P712m", &SA5_access},
	{0x324b103C, "Smart Array P711m", &SA5_access},
	{0x3233103C, "StorageWorks P1210m", &SA5_access},
	{0x333F103C, "StorageWorks P1210m", &SA5_access},
	{0xFFFF103C, "Unknown Smart Array", &SA5_access},
};

I suppose it's time to write some more logic into our kickstart scripts :)
Comment 6 Tony Camuso 2010-08-06 11:32:09 EDT
Yup. 

:)
Comment 7 RHEL Product and Program Management 2010-08-18 17:19:06 EDT
Thank you for your bug report. This issue was evaluated for inclusion
in the current release of Red Hat Enterprise Linux. Unfortunately, we
are unable to address this request in the current release. Because we
are in the final stage of Red Hat Enterprise Linux 6 development, only
significant, release-blocking issues involving serious regressions and
data corruption can be considered.

If you believe this issue meets the release blocking criteria as
defined and communicated to you by your Red Hat Support representative,
please ask your representative to file this issue as a blocker for the
current release. Otherwise, ask that it be evaluated for inclusion in
the next minor release of Red Hat Enterprise Linux.

Note You need to log in before you can comment on or make changes to this bug.