Bug 620544 - ImportError: /usr/lib64/libnotify.so.1: undefined symbol: gdk_screen_make_display_name
Summary: ImportError: /usr/lib64/libnotify.so.1: undefined symbol: gdk_screen_make_dis...
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: notify-python   
(Show other bugs)
Version: 14
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: John Dennis
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-08-02 19:54 UTC by Michael Schwendt
Modified: 2010-08-02 20:06 UTC (History)
2 users (show)

Fixed In Version: 0.1.1-14.fc14
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-08-02 20:06:19 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Michael Schwendt 2010-08-02 19:54:36 UTC
ABRT says this would be a duplicate of bug 532262, but the crash is different.

After upgrading a Fedora 13 installation to Fedora 14 (Branched), ABRT caught this crash in system-config-printer:

ImportError: /usr/lib64/libnotify.so.1: undefined symbol: gdk_screen_make_display_name

$ rpm -q libnotify notify-python
libnotify-0.5.1-1.fc14.x86_64
notify-python-0.1.1-13.fc14.x86_64

$ ldd -r /usr/lib64/libnotify.so.1
        linux-vdso.so.1 =>  (0x00007fff517ff000)
        libdbus-glib-1.so.2 => /usr/lib64/libdbus-glib-1.so.2 (0x00007fe283fab000)
        libdbus-1.so.3 => /lib64/libdbus-1.so.3 (0x00007fe283d67000)
        libpthread.so.0 => /lib64/libpthread.so.0 (0x00007fe283b49000)
        libgobject-2.0.so.0 => /lib64/libgobject-2.0.so.0 (0x00007fe2838fc000)
        libgthread-2.0.so.0 => /lib64/libgthread-2.0.so.0 (0x00007fe2836f8000)
        libgmodule-2.0.so.0 => /lib64/libgmodule-2.0.so.0 (0x00007fe2834f4000)
        librt.so.1 => /lib64/librt.so.1 (0x00007fe2832eb000)
        libglib-2.0.so.0 => /lib64/libglib-2.0.so.0 (0x00007fe282fe9000)
        libc.so.6 => /lib64/libc.so.6 (0x00007fe282c55000)
        /lib64/ld-linux-x86-64.so.2 (0x00007fe2843e8000)
        libdl.so.2 => /lib64/libdl.so.2 (0x00007fe282a51000)
undefined symbol: gdk_screen_make_display_name  (/usr/lib64/libnotify.so.1)
undefined symbol: gdk_window_get_origin (/usr/lib64/libnotify.so.1)
undefined symbol: gtk_status_icon_get_geometry  (/usr/lib64/libnotify.so.1)
undefined symbol: gtk_status_icon_get_x11_window_id     (/usr/lib64/libnotify.so.1)
undefined symbol: gtk_widget_get_allocation     (/usr/lib64/libnotify.so.1)
undefined symbol: gtk_widget_get_has_window     (/usr/lib64/libnotify.so.1)
undefined symbol: gtk_widget_get_screen (/usr/lib64/libnotify.so.1)
undefined symbol: gtk_widget_get_window (/usr/lib64/libnotify.so.1)
undefined symbol: gtk_status_icon_get_type      (/usr/lib64/libnotify.so.1)
undefined symbol: gdk_screen_get_type   (/usr/lib64/libnotify.so.1)
undefined symbol: gtk_widget_get_type   (/usr/lib64/libnotify.so.1)
undefined symbol: gtk_widget_get_allocation     (/usr/lib64/libnotify.so.1)
undefined symbol: gtk_widget_get_screen (/usr/lib64/libnotify.so.1)
undefined symbol: gtk_status_icon_get_geometry  (/usr/lib64/libnotify.so.1)
undefined symbol: gtk_status_icon_get_x11_window_id     (/usr/lib64/libnotify.so.1)
undefined symbol: gtk_widget_get_has_window     (/usr/lib64/libnotify.so.1)
undefined symbol: gdk_screen_make_display_name  (/usr/lib64/libnotify.so.1)
undefined symbol: gdk_window_get_origin (/usr/lib64/libnotify.so.1)
undefined symbol: gtk_widget_get_window (/usr/lib64/libnotify.so.1)

Comment 1 Michael Schwendt 2010-08-02 20:06:19 UTC
Looks like it was a broken temporary work-around in: 0.1.1-13.fc14
http://koji.fedoraproject.org/koji/buildinfo?buildID=187254


Note You need to log in before you can comment on or make changes to this bug.