Bug 62056 - Hang on PCMCIA after unclean shutdown
Summary: Hang on PCMCIA after unclean shutdown
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: kernel-pcmcia-cs   
(Show other bugs)
Version: 7.2
Hardware: i686 Linux
medium
medium
Target Milestone: ---
Assignee: Dave Jones
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-03-27 02:12 UTC by Yaron Minsky
Modified: 2015-01-04 22:01 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-11-25 08:16:36 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Yaron Minsky 2002-03-27 02:12:00 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.9) Gecko/20020313

Description of problem:
If you shut my particular machine down unceremoniously, it will hang on PCMCIA
when you try to reboot it.   I've left it for 20-some minutes and it's still
hung there.  After a normal shutdown this doesn't happen.  Also, once you do
convince it to boot (by skipping PCMCIA in interactive startup mode), you can in
fact start PCMCIA in the normal "/etc/rc.d/init.d/pcmcia start" fashion,
although it seems slow, and I think it's faster if you do "restart" instead of
"start".

This is a fairly new development, and I'm not sure what the cause is.  I did
upgrade the kernel recently, but I still have the old ones around, and booting
from the old kernels doesn't help.  I'm up to date on all RedHat erratas (via
up2date) as of this writing (March 26th).

The laptop is a Dell L400, and the same thing happens whether or not a card is
inserted.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Unceremoniously turn the machine off.
2. Turn it back on.
3. Wait for a long long time.
	

Additional info:

Comment 1 Yaron Minsky 2002-03-27 02:17:41 UTC
On somewhat closer examination, it looks like starting up with
/etc/rc.d/init.d/pcmcia start doesn't exactly work.  It needs to be interrupted
with a Ctrl-C before it finishes, which seems odd.


Note You need to log in before you can comment on or make changes to this bug.