Bug 620574 - Presentation for coccinelle: Start slide is a complete mess
Summary: Presentation for coccinelle: Start slide is a complete mess
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: openoffice.org   
(Show other bugs)
Version: rawhide
Hardware: x86_64
OS: Linux
low
medium
Target Milestone: ---
Assignee: David Tardon
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-08-02 21:30 UTC by Horst H. von Brand
Modified: 2010-08-24 01:24 UTC (History)
2 users (show)

Fixed In Version: openoffice.org-3.3.0-4.1.fc15
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-08-14 06:48:33 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
A presentation showing the problem (51.29 KB, application/vnd.oasis.opendocument.presentation)
2010-08-02 21:30 UTC, Horst H. von Brand
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
OpenOffice.org 113603 None None None Never

Description Horst H. von Brand 2010-08-02 21:30:17 UTC
Created attachment 436135 [details]
A presentation showing the problem

Description of problem:
I got http://coccinelle.lip6.fr/papers/semantic-patches-talk-ols07.odp, and ooimpress shows a complete mess for the first slide.

Version-Release number of selected component (if applicable):
openoffice.org-impress-3.3.0-1.5.fc14.1.x86_64

How reproducible:
No idea. Has happened with this presentation (but I don't use ooimpress that much)

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

Comment 1 Horst H. von Brand 2010-08-02 21:33:42 UTC
Other slides are messed up to, se e.g. slide 6.

Comment 2 David Tardon 2010-08-03 06:19:43 UTC
Thank you for the report! This is a regression since 3.2.1.

Comment 3 David Tardon 2010-08-10 05:31:42 UTC
fix committed, will be in >= 3.3.0-3.3.fc1{4,5}

Comment 4 Fedora Update System 2010-08-11 14:35:35 UTC
openoffice.org-3.3.0-3.3.fc14 has been submitted as an update for Fedora 14.
http://admin.fedoraproject.org/updates/openoffice.org-3.3.0-3.3.fc14

Comment 5 Horst H. von Brand 2010-08-11 19:07:27 UTC
(In reply to comment #4)
> openoffice.org-3.3.0-3.3.fc14 has been submitted as an update for Fedora 14.
> http://admin.fedoraproject.org/updates/openoffice.org-3.3.0-3.3.fc14    

Works fine _for root only_. Starting, e.g. oowriter in a gnome-terminal by hand as a normal user just finishes without even starting the splash screen. Ditto if you give it a file to show. Exit code is 0 (???). A "strace -f oowriter" shows nothing that looks fishy to my (untrained) eyes.

Comment 6 Horst H. von Brand 2010-08-11 19:17:41 UTC
W(In reply to comment #5)
> (In reply to comment #4)
> > openoffice.org-3.3.0-3.3.fc14 has been submitted as an update for Fedora 14.
> > http://admin.fedoraproject.org/updates/openoffice.org-3.3.0-3.3.fc14    
> 
> Works fine _for root only_. Starting, e.g. oowriter in a gnome-terminal by hand
> as a normal user just finishes without even starting the splash screen. Ditto
> if you give it a file to show. Exit code is 0 (???). A "strace -f oowriter"
> shows nothing that looks fishy to my (untrained) eyes.    

Weird... started /usr/lib64/openoffice.org3/simpress.bin directly, and now "ooimpress file.odp" works fine.

Comment 7 Horst H. von Brand 2010-08-12 00:10:13 UTC
Rebooted, now it works OK.

Comment 8 Horst H. von Brand 2010-08-12 19:06:08 UTC
Upstream marks this as fixed by a later build. Time to try that (and not go back to gtk2)? I'm game to test any update (as long as it doesn't eat my files... ;-)

Comment 9 Caolan McNamara 2010-08-12 19:11:33 UTC
What exactly are you asking ? Does this update fix the original problem ?

Comment 10 Fedora Update System 2010-08-12 20:01:17 UTC
openoffice.org-3.3.0-3.3.fc14 has been pushed to the Fedora 14 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update openoffice.org'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/openoffice.org-3.3.0-3.3.fc14

Comment 11 Horst H. von Brand 2010-08-14 04:12:10 UTC
(In reply to comment #9)
> What exactly are you asking ? Does this update fix the original problem ?

I don't know how to install OOo here from source, sorry. Just asking if you are considering that upstream fix instead of going back to gtk2, and volunteering to try out any experimental packages you come up with.

(In reply to comment #10)
> openoffice.org-3.3.0-3.3.fc14 has been pushed to the Fedora 14 testing
> repository.  If problems still persist, please make note of it in this bug
> report.
>  If you want to test the update, you can install it with 
>  su -c 'yum --enablerepo=updates-testing update openoffice.org'.  You can
> provide feedback for this update here:
> http://admin.fedoraproject.org/updates/openoffice.org-3.3.0-3.3.fc14

Thanks. This is rawhide, I got openoffice.org-impress-3.3.0-4.1.fc15.x86_64, and that one works fine AFAICS (just looked at the presentation I reported).

Comment 12 David Tardon 2010-08-14 06:47:39 UTC
(In reply to comment #11)
> (In reply to comment #9)
> > What exactly are you asking ? Does this update fix the original problem ?
> 
> I don't know how to install OOo here from source, sorry. Just asking if you are
> considering that upstream fix instead of going back to gtk2, and volunteering
> to try out any experimental packages you come up with.

Huh? Upstream fix for _what_? The fix for _this_ bug (i.e. bad rendering of math brackets in presentation) is in openoffice.org-3.3.0-3.3.{fc14,fc15} and later. There is no need to build anything from source.

Comment 13 Caolan McNamara 2010-08-14 12:06:38 UTC
The reversion back to gtk2 is unrelated to this, things are reverting back to gtk2 in F14 in general because mclasen is basically pushing the gnome3 and gtk3 plan back to a F-15 target, so I reverted OOo for F-14 back to gtk2 as well.

The upstream fix for the brackets from the linked upstream bug is the one we included to fix this issue, so that's the one we're using here to address this specific issue. Hope that helps clarify

Comment 14 Fedora Update System 2010-08-17 08:25:23 UTC
openoffice.org-3.3.0-4.3.fc14 has been submitted as an update for Fedora 14.
http://admin.fedoraproject.org/updates/openoffice.org-3.3.0-4.3.fc14

Comment 15 Fedora Update System 2010-08-24 01:24:40 UTC
openoffice.org-3.3.0-4.3.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.