Bug 62058 - Environment variables in /etc/profile not loaded
Environment variables in /etc/profile not loaded
Status: CLOSED RAWHIDE
Product: Red Hat Public Beta
Classification: Retired
Component: bash (Show other bugs)
skipjack-beta1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: wdovlrrw
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-03-26 23:19 EST by Gil Chilton
Modified: 2007-04-18 12:41 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-03-31 23:28:17 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Gil Chilton 2002-03-26 23:19:27 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.0)

Description of problem:
After upgrading a 7.2 install, the previously defined environment variables 
in /etc/profile no longer are loaded into the environment.  I can even manually 
execute the script after changing the permissions to execute and the parameters 
still do not load.  I have to cat the file to the monitor and copy and paste 
the export statements to the command line for them to work.  If copy only the 
relevant portions of /etc/profile into a separate file, the same issue remains.

The first time I started up skipjack, I logged in as root, noticed that the 
variables were not loaded, logged out, logged in as a non-root account, still 
did not see the variables, logged out, and logged in as root and suddenly saw 
the variables loaded.  I have not been able to repeat this sequence since.

Version-Release number of selected component (if applicable):


How reproducible:
Sometimes

Steps to Reproduce:
1. Login and look for environment variables in /etc/profile
2. Variables are not setup
3.
	

Actual Results:  No changes defined in /etc/profile or moved to a different 
script are loaded into the environment.

Expected Results:  Environment variables exported in /etc/profile should be 
loaded during login process.

Additional info:
Comment 1 Bill Nottingham 2002-03-27 14:51:28 EST
How are you logging in?
Comment 2 Gil Chilton 2002-03-28 09:32:07 EST
KDE
Comment 3 Gil Chilton 2002-03-28 09:33:11 EST
The problem occurs with KDE but not when I bypass X (Ctrl-Alt-F2) and login 
directly to the machine.
Comment 4 Gil Chilton 2002-03-31 23:28:12 EST
This item appears to be corrected with the updates available via up2date on 
3/29/02.
Comment 5 Bernhard Rosenkraenzer 2002-04-01 04:15:45 EST
Yes, this was caused by bad kdm settings.

Note You need to log in before you can comment on or make changes to this bug.