Bug 620581 - [abrt] virt-manager-0.8.4-3.fc14: Process /usr/bin/python was killed by signal 11 (SIGSEGV)
Summary: [abrt] virt-manager-0.8.4-3.fc14: Process /usr/bin/python was killed by signa...
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: virt-manager   
(Show other bugs)
Version: rawhide
Hardware: x86_64
OS: Linux
low
medium
Target Milestone: ---
Assignee: Cole Robinson
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:99fac80cd45b9919c1a0d529791...
Keywords:
Depends On:
Blocks: Python27
TreeView+ depends on / blocked
 
Reported: 2010-08-02 21:53 UTC by Erik van Pienbroek
Modified: 2010-08-21 23:42 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-08-21 23:42:52 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (93.21 KB, text/plain)
2010-08-02 21:53 UTC, Erik van Pienbroek
no flags Details
backtrace with glib2-debuginfo and gtk2-debuginfo installed (104.70 KB, text/plain)
2010-08-03 17:02 UTC, Erik van Pienbroek
no flags Details

Description Erik van Pienbroek 2010-08-02 21:53:46 UTC
abrt version: 1.1.10
architecture: x86_64
Attached file: backtrace
cmdline: python /usr/share/virt-manager/virt-manager.py
component: virt-manager
executable: /usr/bin/python
kernel: 2.6.33.6-147.2.4.fc13.x86_64
package: virt-manager-0.8.4-3.fc14
rating: 4
reason: Process /usr/bin/python was killed by signal 11 (SIGSEGV)
release: Fedora release 14 (Rawhide)
time: 1280785605
uid: 500

How to reproduce
-----
1. Install the new virt-manager RPM from bug 620216
2. Start virt-manager
3. While remote controlling a guest, virt-manager crashes at random (but quite often)

Comment 1 Erik van Pienbroek 2010-08-02 21:53:50 UTC
Created attachment 436139 [details]
File: backtrace

Comment 2 Dave Malcolm 2010-08-02 22:13:23 UTC
Thanks for filing this bug report

Frame #7:
/usr/share/virt-manager/virtManager/domain.py:1031, in _in_out_vector_helper(self=<vmmDomain

which is:
>>>                    vector.append(float(stats[i][n])/ceil)

Frame #1: float_new(args=(<unknown at remote 0x1be4e08>,))
Frame #0: PyNumber_Float (o=<unknown at remote 0x1be4e08>)

So it looks like its crashing within the float coercion of "stats[i][n]"

Comment 3 Dave Malcolm 2010-08-02 22:22:30 UTC
Assuming correct line numbers, the actual SIGSEGV is happening in:
    m = o->ob_type->tp_as_number;
so it's happening either at the dereference of o, or of o->ob_type.  (My gdb hooks emit "unknown" in safe_tp_name if either of these situations occur; perhaps they should differentiate these cases?)

Comment 4 Dave Malcolm 2010-08-02 22:52:52 UTC
Please can you install pygtk2-debuginfo and supply an updated backtrace?


Thread 2:
waiting on IO from virDomainGetInfo within call:
 frame #9: /usr/lib64/python2.7/site-packages/libvirt.py, line 765, in info
(this uses PyCObject, I wonder if that's an issue?)

 frame #12: /usr/share/virt-manager/virtManager/domain.py, line 1212, in get_info
 frame #15: /usr/share/virt-manager/virtManager/domain.py, line 1920, in tick 

Thread 1:
SIGSEGV coercing an apparently corrupt value to float (c.f. comment #2):
  frame #7: /usr/share/virt-manager/virtManager/domain.py:1031, in_out_vector_helper

  frame #10: /usr/share/virt-manager/virtManager/domain.py, line 1053, in disk_io_vector

  frame #13:  /usr/share/virt-manager/virtManager/domain.py, line 1063, in disk_io_vector_limit

  frame #24 0x0000003f45673a33 in gtk_tree_view_column_cell_set_cell_data ()

etc; gtk main loop, though without debug info in backtrace.


Looks like GTK Tree view cellrenderer for the network activity is requesting data from the app so it can render the network activity graph, but the stored data is corrupt.

Comment 5 Dave Malcolm 2010-08-02 23:56:46 UTC
libvirt-0.8.2/python/typewrappers.c makes use of PyCObject_FromVoidPtrAndDesc in 15 places.

Depending on the warning level (see bug 620216), this can fail on Python 2.7

Not sure that this is the bug, though.

Comment 6 Erik van Pienbroek 2010-08-03 17:02:44 UTC
Created attachment 436328 [details]
backtrace with glib2-debuginfo and gtk2-debuginfo installed

(In reply to comment #4)
> Please can you install pygtk2-debuginfo and supply an updated backtrace?

pygtk2-debuginfo was already installed (it was used in the original bugreport). However, glib2-debuginfo and gtk2-debuginfo weren't installed yet, so I just installed them and regenerated the backtrace.

I think that this bug is triggered every time the guest switches the display resolution

Comment 7 Cole Robinson 2010-08-21 22:19:52 UTC
Can you still reproduce? There was a gtk-vnc update pushed that fixed a VNC crasher, maybe it solved this one as well.

Comment 8 Erik van Pienbroek 2010-08-21 22:27:41 UTC
The problem indeed seems to be solved already by the gtk-vnc update

Comment 9 Cole Robinson 2010-08-21 23:42:52 UTC
Thanks, closing.


Note You need to log in before you can comment on or make changes to this bug.