Bug 620588 - [abrt] crash in fedora-packager-0.5.1.0-1.fc12: __init__.py:694:_findmasterbranch:IndexError: list index out of range
Summary: [abrt] crash in fedora-packager-0.5.1.0-1.fc12: __init__.py:694:_findmasterbr...
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: fedora-packager   
(Show other bugs)
Version: 12
Hardware: x86_64
OS: Linux
low
medium
Target Milestone: ---
Assignee: Dennis Gilmore
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:35e247d9
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-08-02 22:35 UTC by Paul Wouters
Modified: 2013-01-10 06:06 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-08-02 22:51:36 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (798 bytes, text/plain)
2010-08-02 22:35 UTC, Paul Wouters
no flags Details

Description Paul Wouters 2010-08-02 22:35:00 UTC
abrt 1.1.1 detected a crash.

architecture: x86_64
cmdline: /usr/bin/python /usr/bin/fedpkg commit
component: fedora-packager
executable: /usr/bin/fedpkg
kernel: 2.6.32.16-141.fc12.x86_64
package: fedora-packager-0.5.1.0-1.fc12
reason: __init__.py:694:_findmasterbranch:IndexError: list index out of range
release: Fedora release 12 (Constantine)

backtrace
-----
__init__.py:694:_findmasterbranch:IndexError: list index out of range

Traceback (most recent call last):
  File "/usr/bin/fedpkg", line 959, in <module>
    args.command(args)
  File "/usr/bin/fedpkg", line 416, in commit
    mymodule = pyfedpkg.PackageModule(args.path)
  File "/usr/lib/python2.6/site-packages/pyfedpkg/__init__.py", line 744, in __init__
    self.distval = self._findmasterbranch()
  File "/usr/lib/python2.6/site-packages/pyfedpkg/__init__.py", line 694, in _findmasterbranch
    return(int(fedoras[-1].strip('f')) + 1)
IndexError: list index out of range

Local variables in innermost frame:
self: <pyfedpkg.PackageModule instance at 0x2178830>
branchre: <_sre.SRE_Pattern object at 0x2179030>
ref: <git.TagReference "refs/tags/nsd-3_2_4-1_fc13">
fedoras: []
branch: 'master'

Comment 1 Paul Wouters 2010-08-02 22:35:03 UTC
Created attachment 436148 [details]
File: backtrace

Comment 2 Paul Wouters 2010-08-02 22:51:36 UTC
This was due to me using the staging repo instead of the proper production repo.


Note You need to log in before you can comment on or make changes to this bug.