Bug 62059 - tux.init should just pull in a tuxctl.conf file
Summary: tux.init should just pull in a tuxctl.conf file
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Public Beta
Classification: Retired
Component: tux   
(Show other bugs)
Version: skipjack-beta1
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Michael K. Johnson
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-03-27 04:45 UTC by Seth Vidal
Modified: 2007-04-18 16:41 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-03-27 22:03:33 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Seth Vidal 2002-03-27 04:45:43 UTC
Description of Problem:
The /etc/init.d/tux file includes the variable definitions from
/etc/sysconfig/tux - but it only uses the ones it specifically makes use of.

There needs to be an easy way to define any of the other /proc/sys/net/tux
options w/o changing the init script.

I would recommend a /etc/tuxctl.conf file - just like sysctl.conf

then after you load the tux modules - run sysctl -p /etc/tuxctl.conf and bring
in any/all config options from that file.

It would save a lot of pain and annoyance with wanting to add something like
/proc/sys/net/tux/http_dir_indexing = 1 and not get an ugly rpm -V tux

the problem with adding the changes to the normal /etc/sysctl.conf file is that
the tux modules are not loaded when sysctl.conf gets pulled in the first time -
so it can't make settings that don't exist.

and while the /etc/init.d/tux file mentions /etc/sysctl.conf as a config file
for tux it is never used.

I think keeping the /etc/sysconfig/tux file would be useful for things like the
userid to run as  but it would be handy to have the other options be set-able
w/o editing the init script.

I can fix up the tux init script and send a patch if that is useful but I think
it would be a pretty trivial patch :)

Thanks
-sv

Comment 1 Michael K. Johnson 2002-03-27 21:59:36 UTC
hmm, in the start() function, something like:
    [ -f /etc/sysctl.tux ] && sysctl -p /etc/sysctl.tux
(I like that name better because it is clearer)
I don't think I'll actually put the file in place, but
that lets you put it in if you need it.

Comment 2 Seth Vidal 2002-03-27 22:03:28 UTC
works for me-  thanks - I always like the quick turnaround time y'all offer :)



Comment 3 Michael K. Johnson 2002-03-27 22:13:12 UTC
Fixed in tux-2.2.5-1, and you're welcome.  Thanks for the suggestion.


Note You need to log in before you can comment on or make changes to this bug.