Bug 62060 - Vendor monitor strings with double quotes break XF86Config
Vendor monitor strings with double quotes break XF86Config
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: Xconfigurator (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Mike A. Harris
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-03-26 23:52 EST by wdc
Modified: 2007-04-18 12:41 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-03-28 07:47:35 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description wdc 2002-03-26 23:52:49 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.8) Gecko/20020204

Description of problem:
I just worked at configuring an IBM LCD monitor whose name
included a double quote (They were being cute to say it was
a '17"' monitor.

The code in XConfigurator that fetches the vendor strings
has to get a bit more clever to filter out that double quote,
because the resulting XF86Config files would say

"IBM 6251 LCD 17""

And that chokes XFree86.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Run Xconfigurator on an IBM NetVista X series system.
2.View the error messages from the X server when it chokes on the
syntax error.

	

Additional info:
Comment 1 Mike A. Harris 2002-03-28 07:47:28 EST
I can't find that string located anywhere in any of the hardware databases.
Where exactly is this string coming from?
Comment 2 Mike A. Harris 2002-03-28 07:51:13 EST
pts/28 mharris@devel:~/src/redhat/hwdata$ dir
total 1216
drwxrwx---    3 mharris      4096 Mar 28 05:44 ./
drwxrwx---   31 mharris      4096 Mar 18 07:56 ../
-rw-rw----    1 mharris     17992 Jan 30 19:02 COPYING
drwxrwx---    2 mharris      4096 Mar 28 05:44 CVS/
-rw-rw----    1 mharris      2747 Mar 20  2001 CardMonitorCombos
-rw-rw----    1 mharris     69727 Mar 23 04:35 Cards
-rw-rw----    1 mharris     66964 Feb  1 01:52
Cards.ORIGINAL-before-commenting-out-UNSUPPORTED
-rw-rw----    1 mharris     23077 Feb  8 18:49 Cards.diff
-rw-rw----    1 mharris       151 Jan 30 19:02 LICENSE
-rw-rw----    1 mharris      1154 Jan 30 19:02 Makefile
-rw-rw----    1 mharris    202369 Mar  7 11:34 MonitorsDB
-rw-rw----    1 mharris    202430 Feb  3 17:37 MonitorsDB.Iiyama
-rw-rw----    1 mharris       150 Mar 17 12:20 README
-rw-rw----    1 mharris      1264 Mar 22 17:04 hwdata.spec
-rwxrwx---    1 mharris      6114 Feb 27 20:11 inf2mondb.py*
-rwxrwx---    1 mharris      3048 Aug 10  2001 makeids*
-rwxrwx---    1 mharris       171 Dec  2  1998 mconvert*
-rw-rw----    1 mharris    160200 Mar 22 17:04 pci.ids
-rw-rw----    1 mharris    158202 Mar 28 05:44 pcitable
-rw-rw----    1 mharris    166724 Dec 29  1999 printertable
-rw-rw----    1 mharris      2540 Mar 13 19:09 translations
-rw-rw----    1 mharris       374 Mar 14 07:14 upgradelist
-rw-rw----    1 mharris     64140 Mar 14 07:14 usb.ids
pts/28 mharris@devel:~/src/redhat/hwdata$ grep 17\" *
grep: CVS: Is a directory
pcitable:0x1039 0x5517  "unknown"       "Silicon Integrated Systems [SiS]|5517"
pcitable:0x104e 0x0017  "unknown"       "Oak Technology, Inc|OTI-64017"
pcitable:0x104e 0x0217  "unknown"       "Oak Technology, Inc|OTI-64217"
pcitable:0x104e 0x0317  "unknown"       "Oak Technology, Inc|OTI-64317"
pcitable:0x108a 0x0001  "unknown"       "Bit3 Computer Corp.|VME Bridge Model 617"
pcitable:0x1119 0x0006  "gdth"  "ICP Vortex|GDT 6x17"
pcitable:0x11d5 0x0117  "unknown"       "Ikon Corporation|10117"

I did not see that this bug was filed against RHL 7.1 until just now.
Since the data provided doesn't seem to exist in any current databases,
I am assuming that the problem no longer exists in Rawhide using the
latest versions of Xconfigurator and hwdata (new package).
Comment 3 wdc 2002-03-28 13:35:59 EST
I have not studied this very deeply, so I'll ask:

When one does a VESA query of a video monitor to have it describe itself,
isn't there a string returned as the name of the hardware?  It was my guess
that the string returned by the monitor contained a double quote, and that
that string was being passed to soemthing that was crafting the Monitor
section of XF86Config.  Am I being silly here?

-wdc
Comment 4 Mike A. Harris 2002-03-28 13:41:44 EST
The X server does a DDC probe of the monitor if the video card supports doing
such.  If the monitor supports DDC, then the monitor's EDID info is returned
and the EDID value is looked up in the MonitorsDB database.  The EDID
value is typically a string of 7-8 characters generally in the form xxxnnnn.

The field you are refering to is only a textual string for humans to read,
and is not involved in the autodetection process.
Comment 5 wdc 2002-03-28 14:03:34 EST
This is very perplexing.

Well the system I was playing with was a loaner.  We sent it back.
If the problem happens with something I care more about, I'll do additional
sleuthing.  Thanks very much for the help and the clarification.

Note You need to log in before you can comment on or make changes to this bug.