Bug 620606 - Hinting on 'cent' glyph in italic fonts broken
Hinting on 'cent' glyph in italic fonts broken
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: liberation-fonts (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Pravin Satpute
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-08-02 21:08 EDT by Cody Boisclair
Modified: 2012-03-06 14:38 EST (History)
4 users (show)

See Also:
Fixed In Version: liberation-fonts-1.07.2-2.fc16
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-03-06 14:38:32 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Screenshot of the cent glyph as displayed in OpenOffice. (94.40 KB, image/png)
2010-08-02 21:08 EDT, Cody Boisclair
no flags Details

  None (edit)
Description Cody Boisclair 2010-08-02 21:08:55 EDT
Created attachment 436160 [details]
Screenshot of the cent glyph as displayed in OpenOffice.

Description of problem:
The character 'cent' (¢) has been modified in Liberation Mono and Liberation Sans without regenerating hints, as has already been discussed in bug 474522.

Version-Release number of selected component (if applicable):
1.06.0.20100721

How reproducible:
Consistently, as long as bytecode hinting has been turned on.

Steps to Reproduce:
1. Use a version of Freetype with bytecode hinting enabled.
2. Make sure that hinting is set to 'full' in your window manager's appearance preferences.
3. Enter the character ¢ (U+00A2) in an application such as OpenOffice.
4. Set the font to Liberation Sans Italic or Liberation Mono Italic.
  
Actual results:
The cent sign looks correct.

Expected results:
The cent sign is warped beyond recognition.
Comment 1 Cody Boisclair 2010-08-02 21:30:28 EDT
I've been playing around with the font, and it's actually even more complicated than it seemed at first. It's not merely a matter of regenerating instructions; that has, in fact, been done. The problem is that FontForge's auto-instructions conflict with the global instructions which were manually coded by Ascender; the glyph looks slightly better removing instructions entirely.

Would it be better to revert to the 1.03 version of the cent glyph (no cross-bar)? Or just leave the glyph unhinted?
Comment 2 Cody Boisclair 2010-08-02 21:36:08 EDT
The other alternative, of course, is to find a contributor who actually has knowledge of bytecode hinting. I'd fix it myself, except I don't know the slightest thing about TrueType hinting myself.

Anyone here have any knowledge of TrueType instructions who might be able to fix this? (DejaVu contributors, perhaps?)
Comment 3 Pravin Satpute 2010-08-04 04:16:53 EDT
yes, hinting is really presently major thing for liberation
there are few more bugs open for hinting

see #591556

will discuss this in tomorrow fedora i18n meeting
Comment 4 Pravin Satpute 2012-02-09 03:42:53 EST
Removed hinting instruction for cent glyph for now in upstream release 1.07.2
Comment 5 Fedora Update System 2012-02-09 03:44:47 EST
liberation-fonts-1.07.2-1.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/liberation-fonts-1.07.2-1.fc16
Comment 6 Fedora Update System 2012-02-09 19:55:38 EST
Package liberation-fonts-1.07.2-1.fc16:
* should fix your issue,
* was pushed to the Fedora 16 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing liberation-fonts-1.07.2-1.fc16'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-1501/liberation-fonts-1.07.2-1.fc16
then log in and leave karma (feedback).
Comment 7 Fedora Update System 2012-02-13 11:03:43 EST
liberation-fonts-1.07.2-2.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/liberation-fonts-1.07.2-2.fc16
Comment 8 Fedora Update System 2012-03-06 14:38:32 EST
liberation-fonts-1.07.2-2.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.