Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 620612 - fedpkg clone fails perhaps because + in package name
fedpkg clone fails perhaps because + in package name
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: git (Show other bugs)
13
All Linux
low Severity medium
: ---
: ---
Assigned To: Chris Wright
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-08-02 22:12 EDT by Roy Rankin
Modified: 2013-01-10 05:43 EST (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-08-06 15:04:58 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Roy Rankin 2010-08-02 22:12:25 EDT
Description of problem: clone of gtk+extra fails. Looks like + in package name replaced by " "  for git.


Version-Release number of selected component (if applicable):
fedora-packager.noarch 0:0.5.1.0-1.fc13 

How reproducible:


Steps to Reproduce:
1. fedpkg clone -B gtk+extra
2.
3.
  
Actual results:
$ fedpkg clone -B gtk+extra
Cloning into bare repository /home/royr/fedora-git/gtk+extra/fedpkg.git...
bad command: git-upload-pack '/gtk extra'
fatal: The remote end hung up unexpectedly
Could not clone: Command '['git', 'clone', '--bare', 'ssh://rrankin@pkgs.fedoraproject.org/gtk+extra', '/home/royr/fedora-git/gtk+extra/fedpkg.git']' returned non-zero exit status 128


Expected results:
cloning of package environment.

Additional info:
gputils, gpsim, and denemo all cloned OK.
Comment 1 Jesse Keating 2010-08-06 15:04:58 EDT
This is because the version of git you have installed translates the + to spaces.  You need a newer build of git, http://koji.fedoraproject.org/koji/buildinfo?buildID=187168

Note You need to log in before you can comment on or make changes to this bug.