Bug 62062 - kickstart file on cdrom does not work
kickstart file on cdrom does not work
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
Brock Organ
:
Depends On:
Blocks: 61590
  Show dependency treegraph
 
Reported: 2002-03-27 00:10 EST by Jim Wright
Modified: 2007-04-18 12:41 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-03-27 01:37:06 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jim Wright 2002-03-27 00:11:00 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.2.1) Gecko/20010901

Description of problem:
I'm creating an installation cdrom based on the rh72 cdroms.  I have added boot
menu options to install using kickstart.  When I place the kickstart config
files on the cdrom in the root of the iso9660 file system, /sbin/loader is
unable to find them.  It successfully mounts the cdrom and loopback mounts
stage2.img.  Then it decides it will do a kickstart install and attempts to
mount the cdrom again.  This fails, and I drop to an interactive install, which
then fails because it can't mount the cdrom again.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. try it


Actual Results:  ...
trying to mount device hdc
loopfd is 7
kickstarting through devicd hdc
trying to mount device hdc
trying to mount device hdc
...

(or similar)

Expected Results:  ...
trying to mount device hdc
loopfd is 7
kickstarting through devicd hdc
getting ready to spawn shell now
...

(or similar)

Additional info:

The workaround is to put the config files in the initial ram disk and then use
something like "ks=file:/ks.cfg" rather than "ks=cdrom:/ks.cfg".  However, this
is more awkward since every change to the kickstart config file requires
rebuilding the initial ram disk.
Comment 1 Michael Fulbright 2002-03-27 01:36:30 EST
This will be fixed in the next release.
Comment 2 Michael Fulbright 2002-04-09 23:56:46 EDT
Verified fixed.
Comment 3 Andreas Luik 2002-08-28 09:48:51 EDT
Is there any chance of getting this fix in an update package?  Unfortunately,
this fix did not make it into the anaconda errata
http://rhn.redhat.com/errata/RHBA-2002-016.html, which is the latest
anaconda update available.

This bug currently requires us to create kickstart floppies, which we want
to avoid.  Any help to circumvent this is greatly appreciated.  If it's not
possible to get the kickstart file from the CD filesystem, but only from
the initial RAM disk, a pointer to instructions about how to build a new
RAM disk would be very helpful.

Thanks,
Andreas Luik

Note You need to log in before you can comment on or make changes to this bug.